Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#551 - /sys is missing (kernel26)

Attached to Project: Arch Linux
Opened by Damir Perisa (damir.perisa) - Monday, 15 March 2004, 04:40 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

- sysfs in kernel26 needs to be compiled in

http://bbs.archlinux.org/viewtopic.php?t=3193&highlight=
This task depends upon

Closed by  Judd Vinet (judd)
Monday, 15 March 2004, 05:50 GMT
Reason for closing:  Not a bug
Comment by Damir Perisa (damir.perisa) - Monday, 15 March 2004, 04:47 GMT Comment by Judd Vinet (judd) - Monday, 15 March 2004, 04:51 GMT
[jvinet@mars jvinet]$ pacman -Ql filesystem | grep /sys
filesystem /sys/


It's part of the filesystem package already.
Comment by Damir Perisa (damir.perisa) - Monday, 15 March 2004, 05:00 GMT
mount -n -t sysfs /sys /sys

is needed in the start sequence (e.g. from rc.sysinit) to make it working properly

and a fstab-entry is also needed
none /sys sysfs defaults 0 0
Comment by Judd Vinet (judd) - Monday, 15 March 2004, 05:50 GMT
The /sys entry is in the default /etc/fstab already. It is commented out by default, but the installer will uncomment it if the user installs a 2.6.x kernel.

The explicit mount command is not needed, since the "mount -a" command would come right after it and mount /sys anyway (provided there is a /sys entry in fstab).

Re-closing...

Loading...