Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55174 - [sagemath] 8.0-2 gap functionality broken if gap-packages installed

Attached to Project: Community Packages
Opened by Austin (vujazzman) - Thursday, 17 August 2017, 01:14 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 20 August 2017, 08:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Sage functionality relying on Gap is broken if gap-packages is installed.

According to the discussion
https://groups.google.com/forum/#!topic/sage-support/60HHHL8Bw_8
it seems like the issue may be to libgap attempting to load all installed packages on first run, some of which contain functionality unsupported by libgap.

Compiling sage from source and installing packages locally via
sage -i sage_packages
results in a working build

I post this as an archlinux bug because it seems likely the problem arises from the unique way arch packages sagemath, ie installed in system directories and using system versions of its dependencies.

Additional info:
sagemath 8.0-2
gap 4.8.7-3
gap-data 4.8.7-3
gap-packages 4.8.7-3
libgap 4.8.6-3

Steps to reproduce:
$ sage
┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 8.0, Release Date: 2017-07-21 │
│ Type "notebook()" for the browser-based notebook interface. │
│ Type "help()" for help. │
└────────────────────────────────────────────────────────────────────┘
sage: SymmetricGroup(5).conjugacy_classes_subgroups()
Warning: this should never happen
^C
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 20 August 2017, 08:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  gap-packages 4.8.7-4
Comment by Antonio Rojas (arojas) - Saturday, 19 August 2017, 21:57 GMT
Doesn't look related to libgap, seems to be an issue with the pexpect interface. It is caused by the sonata package. Will investigate, for now possible workarounds are:
- Delete /usr/lib/gap/pkg/sonata/
- Remove 'sonata' and 'guava' from line 1527 of /usr/lib/python2.7/site-packages/sage/interfaces/gap.py

Loading...