Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55161 - [clang] Python support should install to the python 3 folder

Attached to Project: Arch Linux
Opened by David Sankel (sankeld) - Wednesday, 16 August 2017, 01:20 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 16 August 2017, 03:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The 4.x versions of clang support Python 3 with their python bindings. The Arch package is still installing these to the python 2.7 folder.


Additional info:
* The problem exists in 4.0.1-5
* You can verify the issue by looking at where the python files are being installed


Steps to reproduce:
Start python3, 'import clang.cindex'
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 16 August 2017, 03:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  OP request: this is only in the unreleased v5.x

Loading...