Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55102 - xf86-video-intel-1:2.99.917+779+g2100efa1-1 causes Xorg to exit

Attached to Project: Arch Linux
Opened by Keenan Conner (duncanyoyo1) - Friday, 11 August 2017, 01:24 GMT
Last edited by Jan de Groot (JGC) - Friday, 11 August 2017, 05:12 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Updating to xf86-video-intel-1:2.99.917+779+g2100efa1-1 Causes Xorg to be unable to start

Additional info:
* package version(s) - xf86-video-intel-1:2.99.917+779+g2100efa1-1
* config and/or log files etc. - Standard Xorg config, using 2 monitors on an Intel HD 3000

[ 102.496] (II) LoadModule: "intel"
[ 102.496] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 102.496] (EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: vgaHWFreeHWRec
[ 102.496] (II) UnloadModule: "intel"
[ 102.496] (II) Unloading intel
[ 102.496] (EE) Failed to load module "intel" (loader failed, 7)
[ 102.496] (EE) No drivers available.
[ 102.496] (EE)
Fatal server error:


Steps to reproduce:

Use an Intel Chipset ( I am using a HD 3000, with an i7-2620m )
This should be all that's needed. Rolling back to 1:2.99.917+777+g6babcf15-1 fixes the problem.

This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 11 August 2017, 05:12 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#54845 

Loading...