Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55099 - [flatpak] Causing cinnamon/gnome to segfault on libmozjs-38

Attached to Project: Arch Linux
Opened by Adam (adam900710) - Thursday, 10 August 2017, 15:42 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 11 November 2019, 07:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Running latest system without any problem before installing flatpak.
However after installing flatpak, cinnamon/gnome will always fail at start due to segfault like:

Aug 10 23:29:57 adam-pc kernel: cinnamon[982]: segfault at 8 ip 00007fe9044fc7b0 sp 00007ffdb03667e8 error 4 in libmozjs-38.so[7fe90400e000+6d5000]
Aug 10 23:29:57 adam-pc systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Aug 10 23:29:57 adam-pc systemd[1]: Started Process Core Dump (PID 994/UID 0).
Aug 10 23:29:58 adam-pc systemd-coredump[995]: Process 982 (cinnamon) of user 1000 dumped core.

Stack trace of thread 982:
#0 0x00007fe9044fc7b0 _Z11JS_GetClassP8JSObject (libmozjs-38.so)
#1 0x00007fe90c2f6ca5 gjs_error_from_gerror (libcjs.so.0)
#2 0x00007fe90c3180ee gjs_throw_g_error (libcjs.so.0)
#3 0x00007fe90c312035 n/a (libcjs.so.0)
#4 0x00007fe90c31210a n/a (libcjs.so.0)
#5 0x00007fe90c313415 n/a (libcjs.so.0)
#6 0x00007fe90425c97c n/a (libmozjs-38.so)
#7 0x00007fe9044fda35 _Z23JS_ForwardGetPropertyToP9JSContextN2JS6HandleIP8JSObjectEENS2_I4jsidEES5_NS1_13Mutabl
#8 0x00007fe90c315f5f _Z27gjs_object_require_propertyP9JSContextN2JS6HandleIP8JSObjectEEPKcNS2_I4jsidEENS1_13Mu
#9 0x00007fe90c304753 n/a (libcjs.so.0)
#10 0x00007fe90425c97c n/a (libmozjs-38.so)
#11 0x00007fe904149709 n/a (libmozjs-38.so)
#12 0x00007fe90424dc7d n/a (libmozjs-38.so)
#13 0x00007fe904257932 n/a (libmozjs-38.so)
#14 0x00007fe904265ec1 n/a (libmozjs-38.so)
#15 0x00007fe904266253 n/a (libmozjs-38.so)
#16 0x00007fe904524728 n/a (libmozjs-38.so)
#17 0x00007fe904524864 _ZN2JS8EvaluateEP9JSContextNS_6HandleIP8JSObjectEERKNS_22ReadOnlyCompileOptionsEPKcmNS_13
#18 0x00007fe90c30c4a2 n/a (libcjs.so.0)
#19 0x00007fe90ce7c1e0 n/a (libgobject-2.0.so.0)
#20 0x00007fe90ce7ddbd g_object_new_valist (libgobject-2.0.so.0)
#21 0x00007fe90ce7e201 g_object_new (libgobject-2.0.so.0)
#22 0x00007fe90e240465 n/a (libcinnamon.so)
#23 0x00007fe90ce9af45 g_type_create_instance (libgobject-2.0.so.0)
#24 0x00007fe90ce7c028 n/a (libgobject-2.0.so.0)
#25 0x00007fe90ce7df9e g_object_new_valist (libgobject-2.0.so.0)
#26 0x00007fe90e2414be _cinnamon_global_init (libcinnamon.so)
#27 0x0000000dbbb8f772 n/a (cinnamon)
#28 0x00007fe90c5b04ca __libc_start_main (libc.so.6)
#29 0x0000000dbbb8f88a n/a (cinnamon)

Additional info:
* package version(s)
extra/flatpak 0.9.7-1
extra/js38 38.8.0-3

* config and/or log files etc.


Steps to reproduce:
1) Make sure your gnome/cinnamon is running fine without installing flatpak
2) Install flatpak
3) Reboot
4) Try to log into your normal gnome/cinnamon session
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 11 November 2019, 07:50 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Thursday, 10 August 2017, 20:44 GMT
Does gnome-shell/gjs crash the same way?
Comment by Adam (adam900710) - Thursday, 10 August 2017, 23:17 GMT
Yes.
Gnome shell and cinnamon both crash in the same way.
Comment by mattia (nTia89) - Tuesday, 05 November 2019, 18:06 GMT
I cannot reproduce the issue.
Can we close the issue?
Comment by Adam (adam900710) - Monday, 11 November 2019, 07:13 GMT
Sure, since I have moved away from GNOME/Cinnamon now.

Loading...