Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55003 - [exiv2] gwenview crash when opening image

Attached to Project: Arch Linux
Opened by Pierre Choffet (Peuc) - Tuesday, 01 August 2017, 17:08 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 17 September 2017, 10:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Last version of Gwenview segfaults when trying to open some jpeg images. Other applications like GIMP and Okular works as expected.

I tried to resize, save, remove EXIF and XMP meta and change compression parameters when editing the file in GIMP, the problem remains in saved images, as long as they remain jpeg.

Additional info:
up to date ArchLinux with Gwenview 17.04.3-2

Gwenview log:
peuc@sz6:tmp$ gwenview IMGP9770.JPG
qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no
Warning: Directory Pentax, entry 0x0004: Data area exceeds data buffer, ignoring it.
Erreur de segmentation (core dumped)
peuc@sz6:tmp$ echo $?
139

Steps to reproduce:
- Download original image (taken with a Pentax camera): http://peuc.net/IMGP9770.JPG
- Try to open it in gwenview
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 17 September 2017, 10:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  exiv2 0.26-2
Comment by Pierre Choffet (Peuc) - Friday, 04 August 2017, 17:00 GMT
Looks like a bug in exiv2. For reference, it's been reported upstream here: http://dev.exiv2.org/issues/1305 .
Comment by Eli Schwartz (eschwartz) - Monday, 04 September 2017, 19:27 GMT
Upstream said "I hope to submit the fix today" and that was on August 8, consider pinging them on their bugtracker about the status of the fix.

Loading...