Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54989 - [libtiff] Backing store not supported

Attached to Project: Arch Linux
Opened by Adam Nielsen (Malvineous) - Monday, 31 July 2017, 13:58 GMT
Last edited by freswa (frederik) - Thursday, 10 September 2020, 12:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since libjpeg-turbo 1.5.2, tiff2pdf can no longer create PDF files, failing with the error "Backing store not supported". libjpeg-turbo 1.5.1 works fine.

I raised a bug upstream[1] and this is an issue where libtiff is setting a hard memory limit of 10MB, which until 1.5.2 libjpeg-turbo was ignoring. Now it is respecting the option, tiff2pdf can't create PDFs as there isn't enough memory.

libjpeg-turbo doesn't consider it their problem (they are doing what was asked) so the solution is to raise the libtiff limit, which looks like it can be done[2] by defining TIFF_JPEG_MAX_MEMORY_TO_USE to be a value larger than 10MB.

I would like to request Arch set it to 128MB or larger during compilation so that large PDF files can be created, restoring the previous behaviour (which was to ignore any memory limit.)

Steps to reproduce:

tiff2pdf -j -q 75 scan.tif > out.pdf

[1]: https://github.com/libjpeg-turbo/libjpeg-turbo/issues/162
[2]: https://github.com/vadz/libtiff/blob/master/libtiff/tif_jpeg.c#L2434-L2443
This task depends upon

Closed by  freswa (frederik)
Thursday, 10 September 2020, 12:59 GMT
Reason for closing:  Fixed

Loading...