Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54981 - [npm] missing semver 5.3.0 modules in npm and node-gyp

Attached to Project: Community Packages
Opened by Gustavo Alvarez (sl1pkn07) - Sunday, 30 July 2017, 19:50 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 31 July 2017, 15:03 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

└───╼ npm -g ls semver
/usr/lib
├─┬ npm@5.3.0
│ ├─┬ init-package-json@1.10.1
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver
│ ├─┬ node-gyp@3.6.2
│ │ └── UNMET DEPENDENCY semver@~5.3.0
│ ├─┬ normalize-package-data@2.4.0
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├─┬ npm-install-checks@3.0.0
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├─┬ npm-package-arg@5.1.2
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├─┬ npm-registry-client@8.4.0
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├─┬ pacote@2.7.38
│ │ ├─┬ npm-pick-manifest@1.0.4
│ │ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├─┬ read-installed@4.0.3
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ ├── UNMET DEPENDENCY semver@~5.3.0
│ └─┬ update-notifier@2.2.0
│ ├─┬ latest-version@3.1.0
│ │ └─┬ package-json@4.0.1
│ │ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
│ └─┬ semver-diff@2.1.0
│ └── semver@5.4.1 -> /usr/lib/node_modules/semver deduped
└── semver@5.4.1

npm ERR! missing: semver@~5.3.0, required by npm@5.3.0
npm ERR! missing: semver@~5.3.0, required by node-gyp@3.6.2


seems need link with semver 5.4.1
This task depends upon

Comment by speedytux (speedytux) - Friday, 03 November 2017, 17:14 GMT Comment by Felix Yan (felixonmars) - Thursday, 09 November 2017, 09:44 GMT
`npm link` somehow doesn't work during package() since recent versions. But this shouldn't cause real errors. Please correct me if it does, though.
Comment by Gustavo Alvarez (sl1pkn07) - Thursday, 05 April 2018, 19:00 GMT
with the workground:

├─┬ npm-lifecycle@2.0.1
│ └─┬ node-gyp@3.6.2
│ └── UNMET DEPENDENCY semver@~5.3.0


npm ERR! missing: semver@~5.3.0, required by node-gyp@3.6.2
Comment by Niccolò Belli (darkbasic) - Wednesday, 25 April 2018, 09:38 GMT
Any chance to fix npm link?
Comment by Luca Franceschini (LucaFranceschini) - Thursday, 20 September 2018, 10:41 GMT
Cannot reproduce the first error, but the node-gyp error is still there.
In order to reproduce it is enough have a clean installation.
Comment by Luca Franceschini (LucaFranceschini) - Wednesday, 03 October 2018, 10:19 GMT
Is moving to node-gyp directory and running npm install a sensible temporary workaround?
Comment by Doron Behar (doronbehar) - Monday, 25 March 2019, 10:55 GMT
Thanks Luca, I think it's a very sensible workaround.
Comment by Charles L (zkmoonea) - Friday, 11 October 2019, 16:17 GMT
I might be wrong. As this post suggests( https://github.com/npm/npm/issues/1341#issuecomment-20634338 ): if we decide to first install both semver and node-pyg, they better be the required versions by npm. Because if their version numbers do not match, when npm is being installed, npm will not again install both packages as sub-dependencies(it believes the top-level packages are already the ones it requires, but they are outdated).
Actually I upgraded node-pyg and npm today to be node-pyg@5.0.3 and npm@6.12.0, while as the package.json of npm@6.12.0 suggests it needs node-pyg@5.0.5. I do not understand the point of setting semver and node-pyg as dependencies of npm in arch repo, as they now sit as top-level packages.

Loading...