Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54975 - [tp_smapi] 0.42-23: Failed to insert 'tp_smapi'

Attached to Project: Community Packages
Opened by Martin Schnitkemper (Martin-MS) - Saturday, 29 July 2017, 23:07 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 04 August 2017, 18:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: After upgraded tp_smapi (0.42-19 -> 0.42-23) error

| Failed to insert 'tp_smapi': No such file or directory

occured.

Additional info: A "modprobe tp_smapi" result in error

| modprobe: ERROR: could not insert 'tp_smapi': Unknown symbol in module, or unknown parameter (see dmesg)

and dmesg reports

| thinkpad_ec: Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0)

* package version(s) 0.42-23

Steps to reproduce: Upgrade to latest version
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 04 August 2017, 18:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.42-25
Comment by Doug Newgard (Scimmia) - Sunday, 30 July 2017, 02:23 GMT
With what kernel? (uname -r)
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 30 July 2017, 07:07 GMT
4.12.3-1-ARCH #1 SMP PREEMPT Sat Jul 22 15:32:02 UTC 2017 x86_64 GNU/Linux
Comment by Jan Alexander Steffens (heftig) - Sunday, 30 July 2017, 20:37 GMT
Should be fixed in 0.42-25 in [community-testing] (goes with linux 4.12.4-1 in [testing]).
Comment by Eli Schwartz (eschwartz) - Sunday, 30 July 2017, 21:14 GMT
# https://bugs.archlinux.org/task/54975 (kernel has no _GLOBAL_OFFSET_TABLE_):
# Clear EXTRA_CFLAGS since it defaults to injecting CFLAGS and -fno-plt breaks the modules

Well, why not just use `CFLAGS=${CFLAGS/-fno-plt/}` then?
Comment by Jan Alexander Steffens (heftig) - Sunday, 30 July 2017, 21:30 GMT
This way you get the same CFLAGS the kernel used.
Comment by Victor Schulz (schulz) - Friday, 04 August 2017, 18:46 GMT
The tp_smapi package was just updated on my machine, and it looks like the bug is fixed.

Loading...