Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54960 - [luxblend25] cannot be installed for i686 due to missing luxrays

Attached to Project: Community Packages
Opened by Erich Eckner (deepthought) - Friday, 28 July 2017, 20:01 GMT
Last edited by Lukas Jirkovsky (6xx) - Wednesday, 02 August 2017, 21:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Jirkovsky (6xx)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

There is no luxrays for i686 since commit 58a5a3143b638b88ee9dfc14801259dbb1be2988

Cheers,
deep42thought
This task depends upon

Closed by  Lukas Jirkovsky (6xx)
Wednesday, 02 August 2017, 21:04 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Friday, 28 July 2017, 20:13 GMT
Oh my, this is an arch=(any) package that depends on two x86_64-only packages. Not sure how that is even supposed to be fixed, *can* we blacklist arch=(any) packages from the i686 repos? (I don't think so.)
Comment by Erich Eckner (deepthought) - Friday, 28 July 2017, 20:15 GMT
the correct way should be to set arch=(x86_64), I think
Comment by Eli Schwartz (eschwartz) - Friday, 28 July 2017, 20:22 GMT
Hardly "correct", since it doesn't contain arch-dependent files. Granted, it is the "most obvious fix" (possibly the only one) for having a package in the i686 repos that cannot be installed.
Comment by Lukas Jirkovsky (6xx) - Wednesday, 02 August 2017, 21:04 GMT
Luxrays/Luxrender are supported only on x86_64 (they don't even compile on i686). However, the luxblend itself is architecture independent, so arch=('any') is the more correct option IMO, though not a perfect one.

Loading...