Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54901 - [matrix-synapse] upgrade from 0.22.1-1 to 0.22.1-2 fails with file conflict

Attached to Project: Community Packages
Opened by Stefan Majewsky (majewsky) - Friday, 21 July 2017, 21:57 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 23 July 2017, 04:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Looks like the python2-bcrypt package needs a replaces=('python2-py-bcrypt'). Shell transcript from my server follows:

$ sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (2) Old Version New Version Net Change

community/matrix-synapse 0.22.1-1 0.22.1-2 0,00 MiB
community/python2-bcrypt 3.1.3-1 0,07 MiB

Total Installed Size: 7,44 MiB
Net Upgrade Size: 0,07 MiB

:: Proceed with installation? [Y/n]
(2/2) checking keys in keyring
(2/2) checking package integrity
(2/2) loading package files
(2/2) checking for file conflicts
error: failed to commit transaction (conflicting files)
python2-bcrypt: /usr/lib/python2.7/site-packages/bcrypt/__init__.py exists in filesystem
python2-bcrypt: /usr/lib/python2.7/site-packages/bcrypt/__init__.pyc exists in filesystem
python2-bcrypt: /usr/lib/python2.7/site-packages/bcrypt/_bcrypt.so exists in filesystem
Errors occurred, no packages were upgraded.

$ pacman -Qi python2-py-bcrypt | grep -E 'Name|Version|Required By'
Name : python2-py-bcrypt
Version : 0.4-2
Required By : matrix-synapse
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 23 July 2017, 04:36 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#54475 
Comment by Doug Newgard (Scimmia) - Saturday, 22 July 2017, 01:49 GMT Comment by Stefan Majewsky (majewsky) - Saturday, 22 July 2017, 14:09 GMT
Re link: That's what I did. "If the file is owned by another package, file a bug report."

The python2-py-bcrypt package was coming from one of the official repos. (As witnessed by matrix-synapse-0.22.1-1 from [community] depending on it.) Here is it in the ALA: https://archive.archlinux.org/packages/p/python2-py-bcrypt/ - It was added on 2017-01-17, four days before the first matrix-synapse appeared in [community] (also according to ALA), so I suppose it was added by the same packager. `pacman -Q` confirms that:

$ pacman -Qi matrix-synapse python2-py-bcrypt | grep -E 'Name|Version|Packager'
Name : matrix-synapse
Version : 0.22.1-1
Packager : Johannes Löthberg <johannes@kyriasis.com>
Name : python2-py-bcrypt
Version : 0.4-2
Packager : Johannes Löthberg <johannes@kyriasis.com>
Comment by Eli Schwartz (eschwartz) - Sunday, 23 July 2017, 04:31 GMT
 FS#54475  was resolved by deleting the python2-py-bcrypt package and making matrix-synapse depend on python2-bcrypt instead.

While one could argue that python2-bcrypt should be updated with a replaces/conflicts, I would hesitate to call that a bug...

Loading...