Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54839 - [kicad] [wxpython] rendering issues with GTK3

Attached to Project: Community Packages
Opened by dhead666 (dhead666) - Sunday, 16 July 2017, 16:16 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Tuesday, 26 December 2017, 16:37 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Kyle Keen (keenerd)
Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Once wxpython-3.0.2.0-4 will enter community expect to hit rendering issues due to the move to GTK3.

I'm not on testing but I built the relate libs a few weeks ago to confirm the issue, it should be visible in the schematic editor, just load any project file and try to move things around.

http://kicad-pcb.org/help/known-system-related-issues/#_legacy_canvas_and_wxgtk
https://forum.kicad.info/t/rendering-issues-on-linux/2518
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Tuesday, 26 December 2017, 16:37 GMT
Reason for closing:  Upstream
Comment by dhead666 (dhead666) - Monday, 17 July 2017, 10:39 GMT
Here's the bug report in Kicad's Launchpad repo https://bugs.launchpad.net/kicad/+bug/1339539
Comment by Eli Schwartz (eschwartz) - Monday, 17 July 2017, 13:42 GMT
kicad upstream says the problem is bugs in wxpython+gtk3, but haven't gotten around to either reporting the bug or creating a minimal test case.
Comment by fseek (fseek) - Tuesday, 19 December 2017, 05:59 GMT
I think the severity should be raised to high since the GTK3 version leads to crashes and lockups in particular with pcbnew which couldn't even draw its ui before crashing.

Unfortunately this makes the whole kicad package entirely non functional in Arch Linux.
Comment by Bruno Pagani (ArchangeGabriel) - Tuesday, 26 December 2017, 16:37 GMT
I’ve removed wxpython from [community-testing], please revert to the one in [community]. Migrating to gtk3 will have to wait for the next release of wxpython (soon™ normally).

Loading...