Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54820 - [glibc] Segmentation fault ld-2.25.so

Attached to Project: Arch Linux
Opened by Filip Gawin (shfil) - Saturday, 15 July 2017, 11:26 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 19 July 2017, 00:26 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Yesterday on my destop pc at some point all programs wasn't able to start. I was constantly getting "Segmentation fault core dumped", after reboot arch welcomed me with kernel panic. I assumed I can easily solve it with chroot. But today it happened on my laptop also. I'm not able to chroot.

Additional info:
* package version(s) ld-2.25
* config and/or log files etc.
Dekstop:
i5 3470
hd 7850(mesa)
8GB ram
500 hdd(seagate)
asrock b75 pro3
bios+gpt, all packages fresh
Laptop:
i5 2520m
hd3000 (mesa)
12GB ram
120ssd(crucial m500)
uefi+gpt, all packages fresh
https://www.flickr.com/photos/156676794@N02/?
(please say if you need better quality, or other files ;) )
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 19 July 2017, 00:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  caused by https://aur.archlinux.org/packages/preli nk
Comment by Filip Gawin (shfil) - Saturday, 15 July 2017, 11:29 GMT
Sorry it's core. How can I change?
Comment by Daniel M. Capella (polyzen) - Saturday, 15 July 2017, 19:50 GMT Comment by Raphaël Doursenaud (rdoursenaud) - Tuesday, 18 July 2017, 12:28 GMT
I've been experiencing the same behavior on both my desktop and my laptop since a few days. I have made sure to fully upgrade the system each time.
Booting to the installer and reinstalling glibc fixes the issue for a while but it creeps back every morning. I keep my machines running and locked with i3lock. Something, somehow, corrupts ld-2.25.so and makes the system unusable. Can't unlock it, can't switch to a VT. Reboot to a kernel panic similar to this report.
Comment by Doug Newgard (Scimmia) - Tuesday, 18 July 2017, 14:33 GMT Comment by Eli Schwartz (eschwartz) - Wednesday, 19 July 2017, 00:25 GMT
So this turns out to have been caused by the AUR package "prelink", rather than partial updates. It would appear that it still isn't an actual bug in our glibc package though. :)

Which makes sense given that glibc works for many people, and "reinstalling glibc fixes the issue for a while but it creeps back every morning" is definitely a sign of something other than glibc corrupting glibc.

Loading...