Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54805 - [systemd] User scope breaks with default 'hybrid' hierarchy

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Friday, 14 July 2017, 13:52 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 14 July 2017, 20:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Currently, systemd is compiled using 'hybrid' default hierarchy.
This causes user scope units to break.

Additional info:
* package version(s): 233.75-3
* config and/or log files etc.

Steps to reproduce:
$ systemctl --version
systemd 233
+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 -SECCOMP +BLKID +ELFUTILS +KMOD +IDN default-hierarchy=hybrid

With hybrid default hierarchy, user scope cannot be created [1].
$ systemd-run --user --scope tmux
Job for run-r23acdbe580484da0a18cc26e940c29b0.scope failed.
See "systemctl status run-r23acdbe580484da0a18cc26e940c29b0.scope" and "journalctl -xe" for details.

A workaround is to add systemd.legacy_systemd_cgroup_controller=true boot parameter to force systemd to use 'legacy' hierarchy instead of using the hierarchy specified during compile time.

I suggest to compile systemd package using 'legacy' cgroup hierarchy until the 'hybrid' or 'unified' cgroup is considered stable.

[1] https://bbs.archlinux.org/viewtopic.php?id=227953
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 14 July 2017, 20:41 GMT
Reason for closing:  Not a bug
Comment by Shane (buffalo) - Friday, 14 July 2017, 17:42 GMT
i made this comment in the wrong thread here. I'm sorry. Can't find a way to delete this.
Comment by John (graysky) - Friday, 14 July 2017, 18:08 GMT
> I suggest to compile systemd package using 'legacy' cgroup hierarchy until the 'hybrid' or 'unified' cgroup is considered stable.

According to the release notes[1], hybrid is the recommended default. I am not agreeing or disagreeing, just pointing it out. Note the third bullet point in the RL speak specifically to this FS.

1. https://lists.freedesktop.org/archives/systemd-devel/2017-March/038419.html

Loading...