Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54735 - [gnuradio-fcdproplus] misses libudev.h during build

Attached to Project: Community Packages
Opened by Erich Eckner (deepthought) - Friday, 07 July 2017, 12:11 GMT
Last edited by Balló György (City-busz) - Sunday, 09 July 2017, 20:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Build in clean chroot fails due to missing / unlocatable libudev.h:

[ 13%] Building C object lib/CMakeFiles/gnuradio-fcdproplus.dir/hid/hid.c.o
/build/gnuradio-fcdproplus/src/gr-fcdproplus/lib/hid/hid.c:44:10: fatal error: libudev.h: No such file or directory
#include <libudev.h>
^~~~~~~~~~~
compilation terminated.

Additional info:
* package version(s)
pkgname=gnuradio-fcdproplus
pkgver=3.7.5
pkgrel=9
* config and/or log files etc.
log is attached

Steps to reproduce:
> git clone 'https://git.archlinux.org/svntogit/community.git/'
> cd community
> git checkout c0b844b85dc6034f516718c7ce97b1f6bab173a8
> cd gnuradio-fcdproplus/trunk
> staging-x86_64-build
   log (14.4 KiB)
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 09 July 2017, 20:22 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Saturday, 08 July 2017, 02:43 GMT
Looks like the deps/makedeps aren't pulling in systemd anymore.
Comment by Balló György (City-busz) - Sunday, 09 July 2017, 20:21 GMT
@keenerd: Please run 'archrelease community-{i686,x86_64}' next time to fix the repos too. We have to ensure that the released packages are buildable.

Loading...