Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54728 - [steam] immediate client crash

Attached to Project: Community Packages
Opened by Chuck (foxcm2000) - Friday, 07 July 2017, 01:30 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 08 July 2017, 02:32 GMT
Task Type Bug Report
Category Packages: Multilib
Status Assigned
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

The steam client has been failing immediately upon launch with an invalid pointer error following an munmap_chunk call since at least this March no matter what I do to try to get it to launch. The closest I can get is to wipe out my steam installation and run 'steam -textclient' that at least downloads the Steam update, but then the program fails after installation. I have installed every single dependency that I can think of and 'steam-runtime' does not give me any warnings about missing dependencies.

The error happens extremely early in the program execution of the steam client. When I say extremely early, I mean the entire backtrace that I generated using GDB [see attachments] from start of the program to the crash only has 12 total frames, and about 5 of them are the program printing out its error message and bailing.

NOTE: I have already tried localegen and setting my environment variables to every language I can think of with no changes to the steam client behavior whatsoever (I did read the wiki page).
Incidentally right now my language is: LANG=en_US.UTF-8

I have also tried setting STEAM_RUNTIME=1 and STEAM_RUNTIME=0 ---> no effect

I have run the "steam-native" command --> no effect

This is a very weird bug that has some similarities to other bugs I've seen around the web but is also different in some ways. Incidentally, I have another system that has practically the same hardware and basically exactly the same software setup in which there is no problem running steam at all!


Additional info:

Hardware/software: Haswell Core i7 and NVidia GTX-1080 running the standard 381.22-1 driver (this bug has been occurring for a long time with different drivers).
Steam 1.0.0.54-1
GL library: lib32-libglvnd & libglvnd both at version 0.2.999+g4ba53457-2
Mesa: 17.1.4 (proprietary Nvidia driver is working fine in other 3D programs)
Plasma desktop 5.10 (same bug occurs in FluxBox too and even with a dummy user account)
Kernel: 4.11.8

* config and/or log files etc.


Steps to reproduce:

Install steam & run to produce instantaneous crash on client launch.

* Attachments:

steam_crash.txt: Contains both the printout from running steam in a terminal and the GDB backtrace at the bottom of the file.
assert_20170706211715_1.dmp: The .dmp file generated by the steam client.

This task depends upon

Comment by Andrey Vihrov (andreyv) - Sunday, 09 July 2017, 11:05 GMT
Is your CPU microcode up to date? https://wiki.archlinux.org/index.php/Microcode
Comment by Chuck (foxcm2000) - Sunday, 09 July 2017, 15:45 GMT
I installed the intel-ucode package and setup the microcode in initrd. No effect.

Here's the output of dmesg piped through a grep for microcode. I think it's working but let me know if you think it's not activated:

[ 0.000000] microcode: microcode updated early to revision 0x22, date = 2017-01-27
[ 1.072980] microcode: sig=0x306c3, pf=0x2, revision=0x22
[ 1.073296] microcode: Microcode Update Driver: v2.2.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Thursday, 11 January 2018, 13:46 GMT
Are all nvidia-related packages (including lib32*) at the same version?

Loading...