Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54644 - [udisks2] Mounting media as user fails with "Mount syscall failed: 13"

Attached to Project: Arch Linux
Opened by Jonathon (jonathon) - Friday, 30 June 2017, 09:41 GMT
Last edited by Felix Yan (felixonmars) - Friday, 14 July 2017, 04:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Attempting to mount an optical disk as a user with `gvfs-mount`, `gio mount`, or `udisksctl` fails.

Mounting directly with `sudo mount` or via fstab entry works as expected.

Additional info:
This is a recent regression but the root cause isn't obvious.

Discovered on Manjaro but replicated by Arch forum mod on plain Arch, please see thread before closing:
https://bbs.archlinux.org/viewtopic.php?id=227791

A Manjaro user also reported failure with a USB device (but not reliably replicated).

Steps to reproduce:
* Insert optical storage medium
* Run `gvfs-mount -d /dev/sr0`
* Observe "Error mounting /dev/sr0 ... Mount syscall failed: 13."

References:
https://bbs.archlinux.org/viewtopic.php?id=227791
https://forum.manjaro.org/t/mount-dvd-error-mount-syscall-failed-13/26750
This task depends upon

Closed by  Felix Yan (felixonmars)
Friday, 14 July 2017, 04:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  libblockdev 2.10
Comment by Maksim (DeadMetaler) - Friday, 30 June 2017, 22:39 GMT
Mount any ISO image with nautilus + gnome-disks or the same result with

udisksctl loop-setup -r -f image.iso

Try to open mounted image and give "Mount syscall failed: 13."
Comment by Aivar Kinski (Aivar) - Saturday, 01 July 2017, 15:03 GMT
I can create a device, but can't mount it:
$ udisksctl mount -b /dev/loop0
==== AUTHENTICATING FOR org.freedesktop.udisks2.filesystem-mount-system ====
Authentication is required to mount /dev/loop0
Authenticating as: root
Password:
==== AUTHENTICATION COMPLETE ====
Error mounting /dev/loop0: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error mounting /dev/loop0 at /run/media/aivar/Slax CD: Mount syscall failed: 13.

The delete of the loop device also requires authentication.
Comment by Jonathon (jonathon) - Sunday, 02 July 2017, 12:47 GMT
This may be related to udisks2=2.7.0. According to Manjaro user, reverting to 2.6.5 "fixes" the issue.
Comment by Paul Marwick (toothandnail) - Friday, 07 July 2017, 23:55 GMT
I'm seeing the same problem in three different Arch installs (two on my T420 Laptop, one on an HP 8200 dekstop). In my case, attempting to mount a bootable USB flash drive fails every time with the same error. Mounting optical disks or non-bootable flash drives works without problems.

Quite specific to Arch - mounting the same bootable flash drives works fine under Sparky Linux, and used to work under Arch.
Comment by Paul Marwick (toothandnail) - Saturday, 08 July 2017, 15:24 GMT
In my case, reverting udisks2 to 2.6.5 also solves the problem - done on all three installs that were showing the problem, all of them are now able to mount bootable flash drives again. Oddly, it was only Linux bootable flash drives that were showing the problem - an 8 GB flash drive of Win10 (also bootable) mounted without error even before changing udisks2.
Comment by Maksim (DeadMetaler) - Monday, 10 July 2017, 10:53 GMT
Wait for update by maintainers libblockdev package to 2.10. Released 5 days ago an contain fix fo this bug.

https://github.com/storaged-project/udisks/issues/334
Comment by Jonathon (jonathon) - Monday, 10 July 2017, 13:22 GMT
I've just picked up udisks2=2.7.1-2 and this is working correctly with libblockdev=2.9-1 on one machine. I'll test more widely a bit later today.
Comment by Paul Marwick (toothandnail) - Monday, 10 July 2017, 13:33 GMT
Just installed udisk2 2.7.1-2 on one Arch install. Restarted the machine, still got the same problem on Linux bootable flash drives. :(
Comment by Paul Marwick (toothandnail) - Tuesday, 11 July 2017, 06:25 GMT
Have to take that last comment back. Just installed it again, this time it has overcome the problem. No idea what I did last night...
Comment by Felix Yan (felixonmars) - Tuesday, 11 July 2017, 06:41 GMT
With updated libblockdev 2.10, anyone still seeing the problem?
Comment by nicholas (nicholas) - Friday, 14 July 2017, 01:18 GMT
I've been seen the problem for a while and the latest update for libblockdev 2.10-1 seems to have resolved the issue finally.

Loading...