Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#5464 - kernel panic on guest under vmware server after upgrade to kernel 2.6.18

Attached to Project: Arch Linux
Opened by Peter Kliment (Pjetko) - Thursday, 28 September 2006, 18:22 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This happened on guest under vmware server 1.0.1 after I upgrade system with "pacman -Sy", "pacman -Su" and edited grub.conf to kernel26.img.
Previous upgrade was approximately before 2 weeks without any problems. If you will need other info contact me. Thanks
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 02 December 2006, 15:59 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Tuesday, 03 October 2006, 12:47 GMT
please try to install this kernel:
http://www.archlinux.org/~tpowa/core-duo/kernel26-2.6.18-6.pkg.tar.gz
i assume you use a core duo pc since those error exactly shows up like this on other core duo setups in forum.
Comment by Peter Kliment (Pjetko) - Tuesday, 03 October 2006, 17:22 GMT
No, I`m don`t use core duo. I have 1 processor virtual machine under vmware server.
Comment by Tobias Powalowski (tpowa) - Tuesday, 03 October 2006, 18:56 GMT
have you installed the new kernel i posted in the link?
Comment by Peter Kliment (Pjetko) - Tuesday, 03 October 2006, 20:38 GMT
No I don't. I'll try this kernel on tomorrow evening. I'll let you now...
Thank you for cooperation.
Comment by Peter Kliment (Pjetko) - Tuesday, 03 October 2006, 21:07 GMT
I tried now with "your" kernel but the problem is same :(.
Comment by Tobias Powalowski (tpowa) - Wednesday, 04 October 2006, 05:40 GMT
ok then try the noapic boot option, it solved quite some issues on the forum and irc
Comment by Peter Kliment (Pjetko) - Friday, 06 October 2006, 12:45 GMT
The problem is somewhere in grub. If I hit escape before boot and manually select option "root(hd0,0)" machine booted without any problem.
Here is my menu.lst

# (0) Arch Linux
title Arch Linux
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/hda1 ro
initrd /boot/kernel26.img
Comment by Peter Kliment (Pjetko) - Friday, 20 October 2006, 17:13 GMT
Grub is OK, I am don`t understand why at that time machine booted.
Here is the debug from booting

Linux version 2.6.18-ARCH (root@Wohnung) (gcc version 4.1.1) #1 SMP PREEMPT Mon Oct 16 10:36:48 CEST 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fef0000 (usable)
BIOS-e820: 000000001fef0000 - 000000001feff000 (ACPI data)
BIOS-e820: 000000001feff000 - 000000001ff00000 (ACPI NVS)
BIOS-e820: 000000001ff00000 - 0000000020000000 (usable)
BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
512MB LOWMEM available.
found SMP MP-table at 000f6ce0
DMI present.
ACPI: PM-Timer IO Port: 0x1008
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:4 APIC version 17
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 17, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
Enabling APIC mode: Flat. Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 30000000 (gap: 20000000:dec00000)
Detected 2999.614 MHz processor.
Built 1 zonelists. Total pages: 131072
Kernel command line: root=/dev/hda1 ro console=ttyS0, 57600 console=tty0
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 515156k/524288k available (2235k kernel code, 8500k reserved, 701k data, 228k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 6020.52 BogoMIPS (lpj=12041051)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 2048K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 12k freed
checking if image is initramfs... it is
Freeing initrd memory: 451k freed
ACPI: Core revision 20060707
ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.
CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 08
Total of 1 processors activated (6020.52 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
------------[ cut here ]------------
kernel BUG at kernel/softirq.c:577!
invalid opcode: 0000 [#1]
PREEMPT SMP
Modules linked in:
CPU: 0
EIP: 0060:[<c012a22e>] Not tainted VLI
EFLAGS: 00010286 (2.6.18-ARCH #1)
EIP is at cpu_callback+0x28e/0x2d0
eax: c1406500 ebx: 00000000 ecx: 00000000 edx: 00fe9500
esi: 00000000 edi: 00000000 ebp: 00000000 esp: dfe41f80
ds: 007b es: 007b ss: 0068
Process swapper (pid: 1, ti=dfe40000 task=c1477ab0 task.ti=dfe40000)
Stack: 00000286 00000000 00000000 00000000 00000000 00000000 00000000 c03f65fc
c0100300 c010034a c0384780 00000000 c03e1fc8 c010318a 00000202 c0100300
00000000 00000000 00000000 00000000 00000000 00000000 0000007b c0100300
Call Trace:
[<c03f65fc>] spawn_ksoftirqd+0x1c/0x40
[<c0100300>] init+0x0/0x330
[<c010034a>] init+0x4a/0x330
[<c010318a>] ret_from_fork+0x6/0x1c
[<c0100300>] init+0x0/0x330
[<c0100300>] init+0x0/0x330
[<c0101005>] kernel_thread_helper+0x5/0x10
Code: 00 00 00 8b 5c 24 10 8b 74 24 14 8b 7c 24 18 83 c4 1c c3 89 d0 e8 03 3c ff ff e9 fe fe ff ff 89 d0 e8 f7 3b ff ff e9 72 fe ff ff <0f> 0b 41 02 2d d3 34 c0 e9 12 ff ff ff 0f 0b 42 02 2d d3 34 c0
EIP: [<c012a22e>] cpu_callback+0x28e/0x2d0 SS:ESP 0068:dfe41f80
<0>Kernel panic - not syncing: Attempted to kill init!
Comment by Peter Kliment (Pjetko) - Friday, 20 October 2006, 17:23 GMT
When I am tried noapic option machine booted, but network didnt work

Linux version 2.6.18-ARCH (root@Wohnung) (gcc version 4.1.1) #1 SMP PREEMPT Mon Oct 16 10:36:48 CEST 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fef0000 (usable)
BIOS-e820: 000000001fef0000 - 000000001feff000 (ACPI data)
BIOS-e820: 000000001feff000 - 000000001ff00000 (ACPI NVS)
BIOS-e820: 000000001ff00000 - 0000000020000000 (usable)
BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
512MB LOWMEM available.
found SMP MP-table at 000f6ce0
DMI present.
ACPI: PM-Timer IO Port: 0x1008
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:4 APIC version 17
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: Skipping IOAPIC probe due to 'noapic' option.
Using ACPI for processor (LAPIC) configuration information
Intel MultiProcessor Specification v1.4
Virtual Wire compatibility mode.
OEM ID: INTEL Product ID: 440BX APIC at: 0xFEE00000
I/O APIC #1 Version 17 at 0xFEC00000.
Enabling APIC mode: Flat. Using 1 I/O APICs
Processors: 1
Allocating PCI resources starting at 30000000 (gap: 20000000:dec00000)
Detected 3000.628 MHz processor.
Built 1 zonelists. Total pages: 131072
Kernel command line: root=/dev/hda1 ro console=ttyS0,57600 console=tty0 noapic
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 515156k/524288k available (2235k kernel code, 8500k reserved, 701k data, 228k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 6021.21 BogoMIPS (lpj=12042423)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 2048K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 12k freed
checking if image is initramfs... it is
Freeing initrd memory: 451k freed
ACPI: Core revision 20060707
ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.
CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 08
Total of 1 processors activated (6021.21 BogoMIPS).
Brought up 1 CPUs
migration_cost=0
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfd9a0, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI quirk: region 1000-103f claimed by PIIX4 ACPI
PCI quirk: region 1040-104f claimed by PIIX4 SMB
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 12 devices
SCSI subsystem initialized
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
PCI: Bridge: 0000:00:01.0
IO window: disabled.
MEM window: disabled.
PREFETCH window: disabled.
NET: Registered protocol family 2
IP route cache hash table entries: 16384 (order: 4, 65536 bytes)
TCP established hash table entries: 65536 (order: 7, 786432 bytes)
TCP bind hash table entries: 32768 (order: 6, 393216 bytes)
TCP: Hash tables configured (established 65536 bind 32768)
TCP reno registered
Simple Boot Flag at 0x36 set to 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
Limiting direct PCI/PCI transfers.
ACPI: AC Adapter [ACAD] (on-line)
ACPI: Power Button (FF) [PWRF]
ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not present [20060707]
ACPI: Getting cpuindex for acpiid 0x1
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not present [20060707]
ACPI: Getting cpuindex for acpiid 0x2
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not present [20060707]
ACPI: Getting cpuindex for acpiid 0x3
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:0a: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
loop: loaded (max 8 devices)
PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUS] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
input: AT Translated Set 2 keyboard as /class/input/input0
Using IPI No-Shortcut mode
ACPI: (supports<6>Time: tsc clocksource has been installed.
S0 S1 S5)
Freeing unused kernel memory: 228k freed
Fusion MPT base driver 3.04.01
Copyright (c) 1999-2005 LSI Logic Corporation
Fusion MPT SPI Host driver 3.04.01
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 9
ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKB] -> GSI 9 (level, low) -> IRQ 9
mptbase: Initiating ioc0 bringup
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=00000000h, Ports=1, MaxQ=128, IRQ=9
PIIX4: IDE controller at PCI slot 0000:00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x1050-0x1057, BIOS settings: hda:DMA, hdb:pio
hda: VMware Virtual IDE Hard Drive, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 128KiB
hda: 20971520 sectors (10737 MB) w/32KiB Cache, CHS=22192/15/63, UDMA(33)
hda: hda1 hda2
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Comment by Tobias Powalowski (tpowa) - Sunday, 05 November 2006, 07:31 GMT
still valid in new kernel 18.2?
Comment by Peter Kliment (Pjetko) - Sunday, 05 November 2006, 12:30 GMT
Unfortunately yes
Comment by eliott (cactus) - Sunday, 05 November 2006, 18:46 GMT
I have the same thing happening to me. I disable apic (noapic), and the vmware instance boots just fine.
With it enabled...kernel panic. Output is nearly identical to the entry: Friday, 20 October 2006, 10:13AM
Comment by Roman Kyrylych (Romashka) - Sunday, 05 November 2006, 19:15 GMT
From which kernel version this happens?
Am I the only one who successfully boots kernel26-2.6.18 in VMware?
Comment by eliott (cactus) - Sunday, 05 November 2006, 19:37 GMT
This happens to me on kernel26 2.6.18.2-1
Comment by Roman Kyrylych (Romashka) - Sunday, 05 November 2006, 20:02 GMT
I'll try it again after pacman -Syu tomorrow.

Please try to change VMware machine's BIOS settings.
Press F2 before grub loads and then try to change some settings.
For all my virtual machines I have floppy/COM/LPT and power saving completely disabled, and enabled 32-Bit IO for HDDs (I always use IDE HDDs), other options are set to default values.
Comment by eliott (cactus) - Sunday, 05 November 2006, 22:16 GMT
I have alot of the settings you have for the vmware bios.
I made some further changes, turning off serial, parallel, and floppy interfaces..
Still the same problem.

Kernel panic when apic is not turned off via a kernel arg in grub.
I consistently get the kernel panic right after...

ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1

found some random info about noapic and vmware..
http://kb.vmware.com/KanisaPlatform/Publishing/329/1420_f.SAL_Public.html

Looks like they recommend it in instances where the guest clock is running too slowly. I found other references to people that needed noapic to boot certain install cd's and distros under vmware.
Odd..this is the first time I have run into this one...
Comment by Roman Kyrylych (Romashka) - Monday, 06 November 2006, 00:39 GMT
Yes, I've read a lot about that problem with clock... I was struggling with it for long time...

Peter Kliment (Pjetko):
> When I am tried noapic option machine booted, but network didnt work

I've never had such problem with noapic option. What network card do you have?
Comment by Roman Kyrylych (Romashka) - Monday, 06 November 2006, 00:46 GMT
> What network card do you have?

Oh, stupid question, this is standard VMware's network card :D (pcnet32).
Comment by Tobias Powalowski (tpowa) - Saturday, 02 December 2006, 15:48 GMT
status on .19 kernel?
Comment by Peter Kliment (Pjetko) - Saturday, 02 December 2006, 15:57 GMT
Today I tried upgrade to current kernel 2.6.18.4-1 with success! With noapic option network card work.
Thank you.

Loading...