Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54611 - [gnome-shell] Pauses for 2-3 seconds. Log message: pushModal: invocation of begin_modal failed

Attached to Project: Arch Linux
Opened by Victor Trac (victortrac) - Tuesday, 27 June 2017, 15:10 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 29 June 2017, 16:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned   Reopened
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
With some recent update, my system is pausing for 2-3 seconds every few minutes. Mouse cursor seems to respond, but not clicks and keyboard input.

Additional info:
* extra/gnome-shell 3.24.2-1
* Log output:
Jun 27 10:04:03 callisto org.gnome.Shell.desktop[1043]: Window manager warning: last_user_time (37464436) is greater than comparison timestamp (37456922). This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE
Jun 27 10:04:03 callisto org.gnome.Shell.desktop[1043]: Window manager warning: 0x2a0000a (Firefox Fo) appears to be one of the offending windows with a timestamp of 37464436. Working around...
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed
Jun 27 10:04:03 callisto gnome-shell[1043]: pushModal: invocation of begin_modal failed



Steps to reproduce:
* Just use the desktop as normally
This task depends upon

Comment by Victor Trac (victortrac) - Tuesday, 27 June 2017, 15:13 GMT
I just noticed it happening without a corresponding pushModal log entry.. Instead, it was a bunch of these (which doesn't seem related, but I'll add it just in case):

Jun 27 10:10:10 callisto google-chrome.desktop[2539]: A Parser-blocking, cross site (i.e. different eTLD+1) script, https://ajax.googleapis.com/ajax/libs/scriptaculous/1.8.1/slider.js, is invoked via document.write. The network request for this script MAY be b
Jun 27 10:10:10 callisto google-chrome.desktop[2539]: A Parser-blocking, cross site (i.e. different eTLD+1) script, https://ajax.googleapis.com/ajax/libs/scriptaculous/1.8.1/sound.js, is invoked via document.write. The network request for this script MAY be bl


Comment by Victor Trac (victortrac) - Wednesday, 28 June 2017, 19:54 GMT
Turns out I'm still getting pauses. The saned problem may have been a separate issue. Same errors with pushModal as before.

Loading...