Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54594 - [openjdk] libreoffice --writer crashes

Attached to Project: Arch Linux
Opened by Luck Darnière (LuX) - Monday, 26 June 2017, 08:15 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 04 September 2017, 11:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Run "libreoffice --writer" or open an ODT/DOC/DOCX document in libreoffice results in a crash. At the contrary, libreoffice itself runs nicely and opens ODS/XLSX documents without problem.

Additional info: 686 architecture

* package version(s)
extra/libcdr 0.1.3-3
extra/libreoffice-still 5.2.7-1
extra/libreoffice-still-fr 5.2.7-1

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 04 September 2017, 11:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  User setup problem solved.
Comment by Luck Darnière (LuX) - Monday, 26 June 2017, 08:26 GMT
Hi!

I forgot to say that running libreoffice (with or without --writer, so it's probably unrelevant) also produces the folloging error message:

** (soffice:863): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-0xv5YDppGS: Connection refused

I have had previously the following message as well, but strangely enough it no longer appears now:

(soffice:2628): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed
Comment by Luck Darnière (LuX) - Monday, 26 June 2017, 08:39 GMT
Sorry for multiple posts...

I have found that the "Gtk-CRITICAL' warning is certainly unrelated to the crash as well: it appears when I open any document using the Gtk dialog, wether or not this document causes a crash to libreoffice.

This error message disappeared after I checked the box "Tools -> Option -> Use libreoffice dialog boxes". It re-appears if I uncheck it. But wether or not it appears, the crashes occure just the same.
Comment by Andreas Radke (AndyRTR) - Monday, 26 June 2017, 13:59 GMT
What vcl do you use (gtk3/gtk2/generic/kde4)?
Comment by Luck Darnière (LuX) - Monday, 26 June 2017, 21:30 GMT
I don't know what vcl means, sorry.
I have gtk2 (2.24.31-1) and gtk3 (3.22.16-1) installed.
I don't have kde installed. My Desktop Environment is xfce.

I have launched libreoffice with or without --writer in xfce, gnome and lxde. Gtk-WARNING messages are different (no message in LXDE, 778 messsages in gnome) but do not depend on wether I add the --writer option or not. And "LANG=C libreoffice --writer" crashes in any case without any new message.

Just in case of:
$ LANG=C pacman -Ss libreoff | grep install
extra/libcdr 0.1.3-3 [installed]
extra/libreoffice-still 5.2.7-1 [installed]
extra/libreoffice-still-fr 5.2.7-1 [installed]
Comment by Giovanni (ksniffer) - Tuesday, 27 June 2017, 09:10 GMT
It crashes at startup me too. It's not a Low Serverity, but High. I cannot use LibreOffice anymore after this update. I'm on a 32 bit.

LANG=C pacman -Ss libreoff | grep install
extra/libcdr 0.1.3-3 [installed]
extra/libreoffice-fresh 5.3.4-1 [installed]
extra/libreoffice-fresh-de 5.3.4-1 [installed]
extra/libreoffice-fresh-en-GB 5.3.4-1 [installed]
extra/libreoffice-fresh-fr 5.3.4-1 [installed]
extra/libreoffice-fresh-it 5.3.4-1 [installed]


libreoffice --writer

** (soffice:1485): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-opwjJREelD: Connessione rifiutata

And then exit.
Comment by Andreas Radke (AndyRTR) - Tuesday, 27 June 2017, 18:26 GMT Comment by Luck Darnière (LuX) - Tuesday, 27 June 2017, 18:59 GMT
I don't use any particular theme or personalisation of libreoffice, except those related to french language (spell checking...).
By the way, "pacman -R libreoffice-still-fr hunspell-fr" didn't change anything.
------
$ cat /etc/profile.d/libreoffice-still.sh
# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=kde4
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

$ cat /etc/profile.d/libreoffice-still.csh
# to force a certain look'n feel

#setenv SAL_USE_VCLPLUGIN gen
#setenv SAL_USE_VCLPLUGIN kde4
#setenv SAL_USE_VCLPLUGIN gtk
#setenv SAL_USE_VCLPLUGIN gtk3

Comment by Andreas Radke (AndyRTR) - Tuesday, 27 June 2017, 19:07 GMT
Then it depends on the auto detection. Depends on your desktop environment. You can also find it under "help/info about LibO".

Most stable vcl are gtk2 and generic. Gtk3 and KDE4 tend to be unstable with certain graphic card drivers.
Comment by Luck Darnière (LuX) - Tuesday, 27 June 2017, 20:38 GMT
I haven't found what is LibO and how to use it.

The variable SAL_USE_VCLPLUGIN is unset in the terminal before I run 'libreoffice &', and still unset after that.

If I set it to 'gen' before running 'libreoffice --writer', it no longer results in a crash. Waouh!
If I set it to 'gtk' it crashes without any error message.
If I set it to 'kde4' or 'gtk3' I get the usual warning below (unrelated to the crash) and then it crashes.

------
$ export SAL_USE_VCLPLUGIN=gtk3 ; libreoffice --writer &

** (soffice:1236): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-tc7AAUm3xD: Connection refused
------

You said this is related to graphic card drivers, so:
------
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
$ pacman -Ss xf86-video | grep instal
extra/xf86-video-intel 1:2.99.917+777+g6babcf15-1 (xorg-drivers) [installé]

Comment by Luck Darnière (LuX) - Tuesday, 27 June 2017, 20:59 GMT
NEW!

I don't know if it's the same bug, but after loading libreoffice (without --writer), if I open the "Tools -> Options..." dialog box and then click on "Internet --> MediaWiki", libreoffice crashes EVEN if I previously set $SAL_USE_VCLPLUGIN to 'gen'.
Comment by Giovanni (ksniffer) - Wednesday, 28 June 2017, 07:51 GMT
You should revert the LibreOffice version!!!! Till 5.3.3 it worked. How can it be possible you update the repository package without to check if the software works or not? A lot of people have this problem.

Calc works.
Impress works.
Draw works.
Math works.

The only piece of software it crashes is Writer. The one I use all the time, everyday. Please revert to 5.3.3.
Comment by Andreas Radke (AndyRTR) - Wednesday, 28 June 2017, 20:07 GMT
LibO Writer works for me, also running intel driver here. You also have the option to fall back to LibO-still branch.
Comment by Luck Darnière (LuX) - Thursday, 29 June 2017, 07:34 GMT
@Andreas :
I don't know if you are answering to me (I said I don't know what is LibO) or to Giovanni, or both.
You talk about "LibO writer" and "fall back to LibO-still branch", so I guess that "LibO" is just an abbreviation for "libreoffice". Is that correct?
But then, let me remind you that I'm already using libreoffice-still branch.

@Giovanni:
I understand your impatience, but please remember that this a free service given by volontaries. It works generally fine, and Andreas is looking for a solution for the present problem. In the meantime, have you tried the work around I found (following Andreas suggestion), to set manually SAL_USE_VCLPLUGIN to 'gen'?
---
$ export SAL_USE_VCLPLUGIN=gen ; libreoffice --writer &
---
This makes libreoffice --writer work for me, provided I don't click on the "Internet --> MediaWiki" option.

@Andreas:
To set this variable to 'gen' works for me (I hope it will work for Giovanni as well), but:
- the graphical interface is disgraced;
- this requires a manual intervention of the user when installing libreoffice;
- the crash when opening "MediaWiki" is still there (I don't know if it's a new bug or if it was allready there).
So I consider it as a temporary work around, not more. Would it be possible to find a better fix?
Comment by Alexander Kaltsas (firewalker) - Saturday, 01 July 2017, 09:52 GMT Comment by Andreas Radke (AndyRTR) - Saturday, 01 July 2017, 10:16 GMT
According to the forum thread it looks more kernel and java related.
Comment by Alexander Kaltsas (firewalker) - Sunday, 02 July 2017, 08:48 GMT
Just a side note. For me libreoffice-fresh works properly. The problem is with libreoffice-still.

4.11.7-1 32-bit.
Comment by Luck Darnière (LuX) - Monday, 10 July 2017, 06:13 GMT
1) I confirm the solution given here by shadowphoton:
https://bbs.archlinux.org/viewtopic.php?pid=1720412#p1720412

- run libreoffice;
- open "Tools->Options->Advanced";
- deselect "Use a Java runtime environment".

After this, "libreoffice --writer" runs like a charm (without changing the default value of SAL_USE_VCLPLUGIN anymore).

2) I confirm also that this is related to the other problem I mentionned: if I click now to "Tools->Options->Internet->MediaWiki" then an alert tells me that this option requires a Java Runtime Environment.
Comment by Luck Darnière (LuX) - Monday, 10 July 2017, 06:33 GMT
By the way, re-installing libreoffice-still-fr works fine but with an error "could not find working directory":

---
$ LANG=C ; pacman -S libreoffice-still-fr
resolving dependencies...
looking for conflicting packages...

Packages (1) libreoffice-still-fr-5.2.7-1

Total Installed Size: 30.10 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [##########################################] 100%
(1/1) checking package integrity [##########################################] 100%
(1/1) loading package files [##########################################] 100%
(1/1) checking for file conflicts [##########################################] 100%
(1/1) checking available disk space [##########################################] 100%
:: Processing package changes...
error: could not get current working directory
(1/1) installing libreoffice-still-fr [##########################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Comment by Alexander Kaltsas (firewalker) - Monday, 10 July 2017, 06:48 GMT
It is just a workaround not a solution.
Comment by Andreas Radke (AndyRTR) - Thursday, 10 August 2017, 20:18 GMT
Fresh and Still branch have seen major updates. Has this been fixed?
Comment by Alexander Kaltsas (firewalker) - Friday, 11 August 2017, 18:15 GMT
It seems to work fine with 5.3.5-1 (Java enabled). 32-bit.
Comment by Luck Darnière (LuX) - Saturday, 12 August 2017, 12:57 GMT
It works with Java... depending on the version.

In "Tools->Options->Advanced", if I select "Use a Java runtime environment", two installed JRE are listed:
a) Oracle Corporation 1.8.0_144
b) Oracle Corporation 1.8.0_151
Apparently I have to choose one of them.

If I select b), "libreoffice --writer" works.
If I select a), it crashes.
Comment by Andreas Radke (AndyRTR) - Sunday, 13 August 2017, 08:34 GMT
This is with our OpenJDK packages?
Comment by Alexander Kaltsas (firewalker) - Sunday, 13 August 2017, 08:44 GMT
for me it works fine with both versions. With our OpenJDK.
Comment by Luck Darnière (LuX) - Sunday, 13 August 2017, 09:58 GMT
I only install package through pacman and exceptionnally yaourt. What else?

$ pacman -Ss openjdk | grep install
extra/jre7-openjdk 7.u151_2.6.11-1 [installed]
extra/jre7-openjdk-headless 7.u151_2.6.11-1 [installed]
extra/jre8-openjdk 8.u144-1 [installed]
extra/jre8-openjdk-headless 8.u144-1 [installed]
Comment by Guillaume ALAUX (galaux) - Wednesday, 16 August 2017, 14:22 GMT
Hi LuX, I am the packager of OpenJDK for Arch Linux.

I just cannot reproduce the crash. I have tried:

- Libreoffice Fresh 5.4.0-2 + OpenJDK 8.u144-1
- Libreoffice Still 5.3.5-1 + OpenJDK 8.u144-1
- Libreoffice Still 5.3.5-1 + OpenJDK 7.u151_2.6.11-1

I have tried to setup LibO with either JDK (7 or 8) and can open ODT as well as DOC and DOCX.

This is not relevant but just to be sure when you mention:
```
a) Oracle Corporation 1.8.0_144
b) Oracle Corporation 1.8.0_151 # ← You actually mean 1.7.0_151
```

Your Java setup could be "messed-up". Could you please try to uninstall both:

```
sudo pacman -Rsndd \
jre7-openjdk-headless \
jre7-openjdk \
jdk7-openjdk \ # if installed
jre8-openjdk-headless \
jre8-openjdk \
jdk8-openjdk # if installed
```

Then `pacman -Syu jdk7-openjdk jdk8-openjdk`, and report back here? Thanks.
Comment by Luck Darnière (LuX) - Wednesday, 16 August 2017, 18:37 GMT
Hi Guillaume

Your solution solved the problem for me (and you're right, the second option was 'Oracle Corporation 1.7.0_151').
Thank you very much for your help!

I noticed that uninstalling an re-installing OpenJDK didn't remove/installed the same packages.
Just for your information, in case of, you will find below the first lines of output of the pacman command you told me to run.
Regards.

--------
$ pacman -Rsndd jre7-openjdk-headless jre7-openjdk jre8-openjdk-headless jre8-openjdk

Paquets (5) java-runtime-common-2-2 jre7-openjdk-7.u151_2.6.11-1 jre7-openjdk-headless-7.u151_2.6.11-1
jre8-openjdk-8.u144-1 jre8-openjdk-headless-8.u144-1

Taille totale supprimée : 171,08 MiB

$$ pacman -Syu jdk7-openjdk jdk8-openjdkx

[*** usual message on synchronisations of the databases ***]

Paquets (8) java-environment-common-2-2 java-runtime-common-2-2 jre7-openjdk-7.u151_2.6.11-1
jre7-openjdk-headless-7.u151_2.6.11-1 jre8-openjdk-8.u144-1 jre8-openjdk-headless-8.u144-1
jdk7-openjdk-7.u151_2.6.11-1 jdk8-openjdk-8.u144-1

Taille totale du téléchargement : 23,34 MiB
Taille totale installée : 228,51 MiB
--------
Comment by Guillaume ALAUX (galaux) - Wednesday, 16 August 2017, 18:51 GMT
> I noticed that uninstalling an re-installing OpenJDK didn't remove/installed the same packages.
Yes: you only had "JRE 7" and "JRE 8" and the line I gave you have installed full "JDK 7" and "JDK 8". I don't mean _you need full JDK for LibreOffice to work_ (I checked and: you don't). What I mean is _your problem must have been some mis-installed JRE_.

Glad it helped :)

@Andreas: So all is good for me. I'll let you close the bug report in case you wanted to have a look at something else – I haven't thoroughly read the bug report.

Loading...