Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54591 - [ghc] Linker cannot find boot libs

Attached to Project: Community Packages
Opened by Phil Ruffwind (Rufflewind) - Sunday, 25 June 2017, 23:58 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 26 June 2017, 01:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Linker cannot find boot libs (base, ghc-prim, rts, etc).

Additional info:
* ghc-8.0.2-1-x86_64
* reproducible on a fresh Arch container

Steps to reproduce:

$ echo 'main = pure ()' >test.hs
$ /usr/bin/ghc test.hs
[1 of 1] Compiling Main ( test.hs, test.o )
Linking test ...
/usr/bin/ld: cannot find -lHSbase-4.9.1.0
/usr/bin/ld: cannot find -lHSinteger-gmp-1.0.0.1
/usr/bin/ld: cannot find -lHSghc-prim-0.5.0.0
/usr/bin/ld: cannot find -lHSrts
collect2: error: ld returned 1 exit status
`gcc' failed in phase `Linker'. (Exit code: 1)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 26 June 2017, 01:25 GMT
Reason for closing:  Not a bug
Comment by Phil Ruffwind (Rufflewind) - Monday, 26 June 2017, 00:00 GMT
Related: https://bugs.archlinux.org/task/54563

Edit:

Workaround: uncomment and add ghc-options: -dynamic to your ~/.cabal/config file.

Loading...