Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54588 - [cgrep] [darcs] [git-annex] [pandoc] Non-upstream change led to enormous dependencies size increase.

Attached to Project: Community Packages
Opened by Alex Vasilenko (krant) - Sunday, 25 June 2017, 18:06 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 25 June 2017, 18:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Flag '--enable-executable-dynamic' was added into PKGBUILDs which led to dependency from whole Haskell development environment. All these packages was rather small, quite generic and used mostly by non-haskellers. Can they be reverted back into static executables?

Here is the list of breaking commits:

cgrep: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/cgrep&id=b243359d5110c089fa8ffe7ee0375ae7f30b3bcc
darcs: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/darcs&id=79505a8e97004f27b571207c382da40d26468878
git-annex: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/git-annex&id=ac9622fdfc251f0412c264342cb4fd548893941d
pandoc: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/pandoc&id=d340c92f8cf5686509551c08bcdaa0b5e66760b0
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 25 June 2017, 18:13 GMT
Reason for closing:  Not a bug

Loading...