Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54526 - idesk does not launch default xpm icon and crashes

Attached to Project: Community Packages
Opened by Miguel Bouza (Raisins4u) - Tuesday, 20 June 2017, 22:55 GMT
Last edited by Balló György (City-busz) - Sunday, 07 January 2018, 21:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
idesk launches the default home icon as an XPM file under the name "folder_home.xpm" when it should be folder_home.png since imlib2 does not load XPM icons. This causes idesk to crash.

Additional info:
* package version(s)
idesk 0.7.5-7

* config and/or log files etc.
default configuration

Steps to reproduce:
-install idesk
-attempt to load, it will crash with an error like this:
"Idesk starting in :0
Can't load: /usr/share/idesk/folder_home.xpm bailing -- Idesk
Check to see if the image and path to image is valid
***** Imlib2 Developer Warning ***** :
This program is calling the Imlib call:
imlib_render_pixmaps_for_whole_image();
With the parameter:
image
being NULL. Please fix your program.
X Error of failed request: BadPixmap (invalid Pixmap parameter)
Major opcode of failed request: 2 (X_ChangeWindowAttributes)
Resource id in failed request: 0x18
Serial number of failed request: 50
Current serial number in output stream: 51"
This task depends upon

Closed by  Balló György (City-busz)
Sunday, 07 January 2018, 21:06 GMT
Reason for closing:  Won't fix
Comment by Sergej Pupykin (sergej) - Thursday, 22 June 2017, 11:55 GMT
I can reproduce it, but it is strange:

$ imlib2_view /usr/share/idesk/folder_home.xpm

command shows icon.
Comment by Balló György (City-busz) - Sunday, 07 January 2018, 21:06 GMT

Loading...