Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54500 - [firefox] firefox 54 missing alsa support, please re-compile with --enable-alsa

Attached to Project: Arch Linux
Opened by patrick (potomac) - Saturday, 17 June 2017, 22:11 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 18 June 2017, 01:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
I upgraded firefox to 54 version,

and I notice the sound doesn't work on PC where sound is managed only by ALSA ( no pulse audio ),

after investigations I notice that the packager has forgotten to use the option "--enable-alsa" for the compilation of firefox,

this made mandatory the use of pulseaudio, which is a very bad idea for people who don't want to use pulse audio ( ALSA can be enough for most of the case ),

please re add the option "-ac_add_options --enable-alsa" in the PKGBUILD

Additional info: firefox-54.0-1-x86_64
* package version(s)
* config and/or log files etc.


Steps to reproduce:
- get a PC with "alsa", and no pulseaudio
- upgrade to firefox 54
- you will unable to hear sound in firefox
- downgrading to firefox 53 : we can hear sound because the package has been build with option "--enable-alsa"
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 18 June 2017, 01:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#53195 
Comment by loqs (loqs) - Saturday, 17 June 2017, 22:34 GMT
See https://bugs.archlinux.org/task/53195#comment155941
can you build firefox 54 successfully with alsa and sandboxing?

Loading...