Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54461 - [duplicity] Missing dep python2-fasteners (AUR)

Attached to Project: Community Packages
Opened by Ole Martin Handeland (olemartinorg) - Thursday, 15 June 2017, 09:51 GMT
Last edited by Lukas Fleischer (lfleischer) - Saturday, 17 June 2017, 18:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Description:
Duplicity does not work after upgrade to duplicity-0.7.13-1, as there's a missing dependency for the 'fasteners' python module. It exists in AUR, but I guess community shouldn't depend on packages from AUR.

From the duplicity 0.7.13 changelog:
* Fixed bug #1320641 and others regarding lockfile
- swap from lockfile to fasteners module

Steps to reproduce:
$ duplicity
Traceback (most recent call last):
File "/usr/bin/duplicity", line 42, in <module>
import fasteners
ImportError: No module named fasteners

This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Saturday, 17 June 2017, 18:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.7.13-2.
Comment by Ole Martin Handeland (olemartinorg) - Thursday, 15 June 2017, 09:53 GMT
Sorry about that, this is my first time reporting a task, and I didn't notice the missing summary. Can't seem to edit now either.
Comment by Kevin (HarlemSquirrel) - Friday, 16 June 2017, 00:59 GMT
The dependency was changed.

Fixed bug #1320641 and others regarding lockfile
- swap from lockfile to fasteners module

http://www.nongnu.org/duplicity/CHANGELOG
Comment by Pierre Schmitz (Pierre) - Friday, 16 June 2017, 10:03 GMT
In addition to this the "monotonic" is missing.
Comment by Lee (faultylee) - Friday, 16 June 2017, 23:53 GMT
in summary, installing these 2 packages fixes the problem
- community/python2-monotonic
- aur/python2-fasteners
Comment by Johannes Maibaum (jmx) - Saturday, 17 June 2017, 09:12 GMT
Actually, python2-monotonic seems to be a dependency of python2-fasteners:

$ duplicity --version
Traceback (most recent call last):
File "/usr/bin/duplicity", line 42, in <module>
import fasteners
File "/usr/lib/python2.7/site-packages/fasteners/__init__.py", line 23, in <module>
from fasteners.lock import locked # noqa
File "/usr/lib/python2.7/site-packages/fasteners/lock.py", line 24, in <module>
from fasteners import _utils
File "/usr/lib/python2.7/site-packages/fasteners/_utils.py", line 22, in <module>
from monotonic import monotonic as now # noqa
ImportError: No module named monotonic

So the former should be a dependency of the latter, and not of duplicity.
Comment by Lee (faultylee) - Saturday, 17 June 2017, 10:30 GMT
When I only install python2-fasteners, I still get this:

$ duplicity --version
Traceback (most recent call last):
File "/usr/bin/duplicity", line 42, in <module>
import fasteners
File "/usr/lib/python2.7/site-packages/fasteners/__init__.py", line 23, in <module>
from fasteners.lock import locked # noqa
File "/usr/lib/python2.7/site-packages/fasteners/lock.py", line 24, in <module>
from fasteners import _utils
File "/usr/lib/python2.7/site-packages/fasteners/_utils.py", line 22, in <module>
from monotonic import monotonic as now # noqa
ImportError: No module named monotonic

Installing python2-monotonic fixed that. I don't see python2-monotonic mentioned as it's dependency here https://aur.archlinux.org/packages/python2-fasteners/
Comment by Oscar Garcia (ogarcia) - Saturday, 17 June 2017, 10:39 GMT
python2-fasteners is out of date in AUR and it have missing dependency of python2-monotonic.

You can see this dependency on pypi [1] (Requires Distributions section).

[1]: https://pypi.python.org/pypi/fasteners
Comment by Johannes Maibaum (jmx) - Saturday, 17 June 2017, 10:41 GMT
Well, that's what I indicated with my previous comment. python2-fasteners has been left unmaintained in the AUR for almost 1.5 years. This should be fixed first, and the package moved to community before any updates to duplicity can be pushed.
Comment by Sydney Dykstra (sydneyd) - Saturday, 17 June 2017, 13:36 GMT
It seems one of the package maintainers has just added python2-fasteners to the Community repository, and you can now install python2-fasteners without using the AUR. I've tested this and it works for me.
https://www.archlinux.org/packages/community/any/python-fasteners/
Comment by Lee (faultylee) - Saturday, 17 June 2017, 14:17 GMT
Confirmed, I just tried, and the dependency for monotonic is included
Comment by Kevin (HarlemSquirrel) - Saturday, 17 June 2017, 15:05 GMT
I can confirm all is working for me as well. Now someone just needs to replace python2-lockfile with python2-fastenrs as a dependency for duplicity.

Loading...