Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#54455 - [networkmanager] Search Domain Not Added Above v.1.6.2-3

Attached to Project: Arch Linux
Opened by baggar11 (baggar11) - Wednesday, 14 June 2017, 20:11 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 17 June 2017, 13:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


NetworkManager versions above v1.6.2-3 do not always add search domain to resolv.conf. I have noticed that my home network domain of "home" is not getting added. I even tried changing my local domain to "localdomain." At my work, a domain of "" gets added fine. Perhaps something with single domain names? I've tried every version above 1.6.2-3 with the same results. Attached are the logs from "journalctl -u NetworkManager" for both v1.6.2-3 and v1.8.0-1. I have only produced the issue on x86_64 but may be present on i686 builds.

Other reports:

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 17 June 2017, 13:53 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 14 June 2017, 22:40 GMT
Looking in git, I can find this:

Networkmanager validates DNS suffix using libpsl, "home", "lan" and "localdomain" are not valid as public suffix so they are ignored.

Comment by baggar11 (baggar11) - Thursday, 15 June 2017, 02:25 GMT
From my logs, I'm using a private 192.168.x.x class c subnet, not public. Is there a portion of libpsl that deals with private domains?