Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54450 - [chromium] 59 breaks Slack calls

Attached to Project: Arch Linux
Opened by Jan Steffens (heftig) - Wednesday, 14 June 2017, 09:06 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 18 October 2017, 07:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Attempt to start an audio call at https://slack.com/.
No actual peers are necessary; not even calls to empty channels work.

With chromium 58.0.3029.110-1 it works,
with chromium 59.0.3071.86-1 it's broken and reports that the connection to the server could not be established.

Slack uses Janus as its WebRTC framework and the Janus Echo demo at https://janus.conf.meetecho.com/echotest.html is also broken since 59.
It reports a "DevicesNotFoundError" without any further details.

Steps to reproduce:
1. Visit https://janus.conf.meetecho.com/echotest.html
2. Click the "Start" button next to the page heading.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 18 October 2017, 07:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  According to the upstream bug, web cameras that report invalid FPS should now work again in Chromium 62.
Comment by Evangelos Foutras (foutrelis) - Friday, 16 June 2017, 20:02 GMT
Did you figure it out? (Seems to work OK for me.)
Comment by Jan Steffens (heftig) - Friday, 16 June 2017, 21:41 GMT
Do you have a camera? Seems it's only broken if video input is available.
Comment by Jan Steffens (heftig) - Friday, 16 June 2017, 21:44 GMT
navigator.mediaDevices.getUserMedia({video: true});

This fails even though navigator.mediaDevices.enumerateDevices() shows I have a videoinput available.
Comment by Jan Steffens (heftig) - Monday, 19 June 2017, 08:37 GMT
My notebook at home (with a "BisonCam") seems to work fine. My work PC (with an old Logitech QuickCam Messenger) is broken.

v4l2-ctl for the QuickCam: https://paste.xinu.at/DBHb2/

gst-device-monitor-1.0 for both: https://paste.xinu.at/m-jj33Xs/
Comment by Jan Steffens (heftig) - Monday, 19 June 2017, 10:39 GMT
Removed the QuickCam, now calls work again.
Comment by Evangelos Foutras (foutrelis) - Thursday, 20 July 2017, 19:08 GMT Comment by Diego Viola (diegoviola) - Saturday, 22 July 2017, 04:10 GMT
I'm also affected by this bug, my webcam is:

Bus 005 Device 002: ID 0ac8:307b Z-Star Microelectronics Corp. USB 1.1 Webcam
Comment by Diego Viola (diegoviola) - Wednesday, 26 July 2017, 17:27 GMT
Still a problem with chromium 60.0.3112.78-1.

Loading...