Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54447 - [jemalloc] 5.0.0-1 breaks community/neovim

Attached to Project: Arch Linux
Opened by Marius O. (lpbm) - Wednesday, 14 June 2017, 08:27 GMT
Last edited by Christian Hesse (eworm) - Thursday, 15 June 2017, 14:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Christian Hesse (eworm)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

When updating jemalloc package from 4.5.0-1 to 5.0.0-1 neovim crashes every time.

Additional info:
* jemalloc 5.0.0 and neovim 0.2.0
* I have the coredumpctl output, but I doubt it's very useful as there are no debug symbols installed.

$ coredumpctl dump 30244
PID: 30244 (vim)
UID: 1000 (h....m)
GID: 1000 (h....m)
Signal: 6 (ABRT)
Timestamp: Wed 2017-06-14 10:07:45 CEST (14min ago)
Command Line: nvim
Executable: /usr/bin/nvim
Control Group: /user.slice/user-1000.slice/session-c4.scope
Unit: session-c4.scope
Slice: user-1000.slice
Session: c4
Owner UID: 1000 (h....m)
Boot ID: 367f0b3bd15e443dbaa83aeb8aadb46f
Machine ID: 60f03413435840c78eec64cafd554d05
Hostname: j...s
Storage: /var/lib/systemd/coredump/core.nvim.1000.367f0b3bd15e443dbaa83aeb8aadb46f.30244.1497427665000000.lz4
Message: Process 30244 (nvim) of user 1000 dumped core.

Stack trace of thread 30244:
#0 0x00007f862a4f4670 raise (libc.so.6)
#1 0x00007f862a4f5d00 abort (libc.so.6)
#2 0x00007f862a87f89b n/a (libjemalloc.so.2)
#3 0x00007f862a86e630 n/a (libjemalloc.so.2)
#4 0x00007f862a8705b5 malloc (libjemalloc.so.2)
#5 0x00007f8629ba0266 pool (libstdc++.so.6)
#6 0x00007f862be8019a call_init.part.0 (ld-linux-x86-64.so.2)
#7 0x00007f862be802a6 _dl_init (ld-linux-x86-64.so.2)
#8 0x00007f862be71dba _dl_start_user (ld-linux-x86-64.so.2)


Steps to reproduce:
$ nvim
<jemalloc>: Error in dlsym(RTLD_NEXT, "pthread_create")

Workarounds:
Downgraded back to jemalloc 4.5.0
This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 15 June 2017, 14:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  jemalloc 5.0.0-2
Comment by teraflops (teraflops) - Wednesday, 14 June 2017, 11:24 GMT
same issue here, tried rebuilding neovim. same error
Comment by Earnestly (Earnest) - Wednesday, 14 June 2017, 18:06 GMT Comment by cotko (cotko) - Thursday, 15 June 2017, 07:07 GMT
same problem with nvim, thanks to Marius for the hint, spared me a morning headache:)
Comment by Earnestly (Earnest) - Thursday, 15 June 2017, 13:11 GMT

Loading...