Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54399 - [beignet] Crash with darktable

Attached to Project: Community Packages
Opened by François Guerraz (kubrick) - Saturday, 10 June 2017, 17:54 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Tuesday, 26 December 2017, 13:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With darktable-git, compiling kernels results in a crash in libgbe.so

Additional info:
* package version(s): beignet 1.3.1-3


Steps to reproduce:

#0 0x00007f62fa02c237 in waitpid () at /usr/lib/libpthread.so.0
#1 0x00007f62fa306718 in _dt_sigsegv_handler (param=11) at /home/xx/Downloads/darktable-fdc/src/common/system_signal_handling.c:118
#2 0x00007f62f9ca96f0 in <signal handler called> () at /usr/lib/libc.so.6
#3 0x00007f62cabdfe6b in () at /usr/lib/beignet//libgbe.so
#4 0x00007f62cabe3a05 in () at /usr/lib/beignet//libgbe.so
#5 0x00007f62cabe3d8f in () at /usr/lib/beignet//libgbe.so
#6 0x00007f62c1554b32 in llvm::FPPassManager::runOnFunction(llvm::Function&) () at /usr/lib/libLLVM-4.0.so
#7 0x00007f62c204fb1f in () at /usr/lib/libLLVM-4.0.so
#8 0x00007f62c1555584 in llvm::legacy::PassManagerImpl::run(llvm::Module&) () at /usr/lib/libLLVM-4.0.so
#9 0x00007f62cac1911f in () at /usr/lib/beignet//libgbe.so
#10 0x00007f62cab83da7 in () at /usr/lib/beignet//libgbe.so
#11 0x00007f62cacdd682 in () at /usr/lib/beignet//libgbe.so
#12 0x00007f62cab940d5 in () at /usr/lib/beignet//libgbe.so
#13 0x00007f62e41a1f28 in () at /usr/lib/beignet//libcl.so
#14 0x00007f62e4197788 in clBuildProgram () at /usr/lib/beignet//libcl.so
#15 0x00007f62e441065b in clBuildProgram () at /usr/lib/libOpenCL.so
#16 0x00007f62fa30e013 in dt_opencl_build_program (dev=dev@entry=0, prog=prog@entry=0, binname=binname@entry=0x7fff377cc0c0 "/home/xx/.cache/darktable/cached_kernels_for_IntelRHDGraphicsSkylakeULTGT3/demosaic_ppg.cl.bin", cachedir=cachedir@entry=0x7fff377c80c0 "/home/xx/.cache/darktable/cached_kernels_for_IntelRHDGraphicsSkylakeULTGT3", md5sum=md5sum@entry=0x7fff377c6c30 "5aee031e10f297312e318ce0b15d81cb", loaded_cached=0) at /home/xx/Downloads/darktable-fdc/src/common/opencl.c:1668
#17 0x00007f62fa30f3a2 in dt_opencl_device_init (cl=cl@entry=0x22a3380, dev=dev@entry=0, devices=devices@entry=0x20709d0, k=k@entry=0, opencl_memory_requirement=opencl_memory_requirement@entry=768) at /home/xx/Downloads/darktable-fdc/src/common/opencl.c:444
#18 0x00007f62fa3146ef in dt_opencl_init (cl=0x22a3380, exclude_opencl=<optimized out>, print_statistics=<optimized out>) at /home/xx/Downloads/darktable-fdc/src/common/opencl.c:661
#19 0x00007f62fa2bec64 in dt_init (argc=<optimized out>, argv=<optimized out>, init_gui=init_gui@entry=1, load_data=load_data@entry=1, L=L@entry=0x0) at /home/xx/Downloads/darktable-fdc/src/common/darktable.c:905
#20 0x00000000004006f6 in main (argc=<optimized out>, argv=<optimized out>) at /home/xx/Downloads/darktable-fdc/src/main.c:24
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Tuesday, 26 December 2017, 13:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  Beignet was initially recompiled against LLVM 3.9 to fix this, but now there is a new release out for LLVM 4 and 5 support, so let’s close this.
Comment by François Guerraz (kubrick) - Saturday, 10 June 2017, 18:08 GMT
better backtrace with debug
Comment by Bruno Pagani (ArchangeGabriel) - Saturday, 17 June 2017, 14:25 GMT
Upstream at https://redmine.darktable.org/issues/11648, originating from https://bugzilla.redhat.com/show_bug.cgi?id=1460400.

Can you confirm you did not manually whitelist beignet?
Comment by François Guerraz (kubrick) - Saturday, 17 June 2017, 18:49 GMT
I did whitelist beignet, I'm not reporting the bug against darktable but against beignet (as advised by a darktable developer on IRC).
Comment by François Guerraz (kubrick) - Saturday, 17 June 2017, 18:51 GMT
LebedevRI i assume there is no opencl?
francois_ no
darktable doesn't like beignet :)
(it used to work by disabling the blacklist but now it just plain crashes)
10 June, 19∶47
LebedevRI haha
make sure to report to the beignet package of your distro
francois_ I though devs didn't want to hear about beignet, that it was just unsupported?
should I open a bug report?
LebedevRI >to the beignet package of your distro
Comment by Bruno Pagani (ArchangeGabriel) - Saturday, 17 June 2017, 20:03 GMT
OK, I see. I can reproduce this even with darktable from repo (which match what is reported at RedHat). Opening a bug upstream at: https://bugs.freedesktop.org/show_bug.cgi?id=101485.
Comment by Bruno Pagani (ArchangeGabriel) - Friday, 27 October 2017, 16:13 GMT
This was fixed by building beignet against llvm39.

But now beignet 1.3.2 is out with LLVM 5.0 support. I’ve pushed it to [community-testing], can you try and report?
Comment by Bruno Pagani (ArchangeGabriel) - Tuesday, 26 December 2017, 13:03 GMT
I’ve moved beignet to [community] since I don’t want to wait any longer for answers here.

Loading...