Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#54384 - [pacman] makepkg ignores CARCH in package function

Attached to Project: Pacman
Opened by Erich Eckner (deepthought) - Friday, 09 June 2017, 10:09 GMT
Last edited by Allan McRae (Allan) - Saturday, 10 June 2017, 07:11 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If environment variable CARCH is set to something, it's taken into account outside of package(), but it's getting ignored inside package().
Being inside gens/repos/multilib-x86_64 from community (I attached the PKGBUILD for reference):

> CARCH=i686 makepkg --printsrcinfo
pkgbase = gens
pkgdesc = A Sega Genesis / Sega CD / Sega 32X emulator
pkgver = 2.15.5
pkgrel = 10
url = http://gens.sourceforge.net
arch = i686
arch = x86_64
license = GPL
makedepends = gendesk
makedepends = imagemagick
makedepends = nasm
depends = gtk2
depends = sdl
options = !buildflags
source = http://downloads.sourceforge.net/gens/gens-2.15.5.tar.gz
sha256sums = 51910d3056da9ffbb2c01cfec064998c9a4cad0cb379d703ec1b93c83dba305a

pkgname = gens
depends = lib32-gtk2
depends = lib32-sdl
   PKGBUILD (1.6 KiB)
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 10 June 2017, 07:11 GMT
Reason for closing:  Not a bug
Comment by Andrew Gregory (andrewgregory) - Friday, 09 June 2017, 16:13 GMT
That method of specifying architecture-specific dependencies is not supported for --printsrcinfo. It should be using depends_x86_64 and depends_i686.

Loading...