Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54333 - [gnuradio] gnuradio-companion: unneeded depends

Attached to Project: Community Packages
Opened by dhead666 (dhead666) - Wednesday, 07 June 2017, 01:36 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 07 June 2017, 15:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

IIUC gnuradio-companion being built with static libs.
I notice that because I built wxgtk and wxpython with gtk3 and without gtk2 support but gnuradio-companion continue working with no rebuild needed and it still uses gtk2 widgets.

# namcap gnuradio-companion-3.7.11-2-x86_64.pkg.tar.xz
gnuradio-companion W: No ELF files and not an "any" package
gnuradio-companion W: Dependency included and not needed ('gnuradio')
gnuradio-companion W: Dependency included and not needed ('python2-cheetah')
gnuradio-companion W: Dependency included and not needed ('python2-lxml')
gnuradio-companion W: Dependency included and not needed ('pygtk')
gnuradio-companion W: Dependency included and not needed ('wxpython')
gnuradio-companion W: Dependency included and not needed ('python2-opengl')
gnuradio-companion W: Dependency included and not needed ('python2-pyqwt')
gnuradio-companion W: Dependency included and not needed ('qwtplot3d')
gnuradio-companion W: Dependency included and not needed ('python2-numarray')
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 07 June 2017, 15:01 GMT
Reason for closing:  Not a bug
Additional comments about closing:  uses pygtk

Loading...