Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54326 - [git] send-email broken in perl Net/SMTP/SSL.pm

Attached to Project: Arch Linux
Opened by Liam (networkimprov) - Tuesday, 06 June 2017, 18:48 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 06 June 2017, 20:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is configured to send via a gmail account
git send-email --to-cover --cc-cover <patch-list>

I See
Attempt to reload IO/Socket/SSL.pm aborted.
Compilation failed in require at /usr/share/perl5/site_perl/Net/SMTP/SSL.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/site_perl/Net/SMTP/SSL.pm line 6.
Compilation failed in require at /usr/lib/git-core/git-send-email line 1386.
fatal: 'send-email' appears to be a git command, but we were not
able to execute it. Maybe git-send-email is broken?

If I comment out "use IO::Socket::SSL;" in */Net/SMTP/SSL.pm, I see
Not using SSL_VERIFY_PEER due to out-of-date IO::Socket::SSL.
Can't locate object method "start_SSL" via package "Net::SMTP::SSL" at /usr/lib/git-core/git-send-email line 1390.


Latest system and git (git-2.13.0-2) with optional packages:
perl-mime-tools perl-net-smtp-ssl perl-authen-sasl

This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 06 June 2017, 20:59 GMT
Reason for closing:  Not a bug
Additional comments about closing:  No package in the repos installs to site_perl
Comment by Florian Pritz (bluewind) - Tuesday, 06 June 2017, 20:50 GMT
What does `pacman -Qo /usr/share/perl5/site_perl/Net/SMTP/SSL.pm` output?

Assuming it outputs "No package ownes $path", you most likely installed some perl modules with cpan directly. This is not supported and you need to remove or rebuild them. If you have one you'll probably have others which also need to be removed/rebuilt.

Loading...