Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54280 - [apm] needs to be rebuilt for nodejs 8

Attached to Project: Community Packages
Opened by Sébastien Luttringer (seblu) - Friday, 02 June 2017, 23:30 GMT
Last edited by Nicola Squartini (tensor5) - Sunday, 04 June 2017, 03:02 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Felix Yan (felixonmars)
Nicola Squartini (tensor5)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: atom package modules are built against an old version of nodejs.

$ pacman -Q nodejs atom
nodejs 8.0.0-1
atom 1.17.2-1

Here is the textual output.

Fetching featured packages failed.Hide output…
module.js:598
return process.dlopen(module, path._makeLong(filename));
^

Error: The module '/usr/lib/node_modules/atom-package-manager/node_modules/git-utils/build/Release/git.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 51. This version of Node.js requires
NODE_MODULE_VERSION 57. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
at Object.Module._extensions..node (module.js:598:18)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/usr/lib/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:8:16)
at Object.<anonymous> (/usr/lib/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:371:4)
at Module._compile (module.js:569:30)
at Object.Module._extensions..js (module.js:580:10)
This task depends upon

Closed by  Nicola Squartini (tensor5)
Sunday, 04 June 2017, 03:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  apm 1.18.2-2
Comment by Sébastien Luttringer (seblu) - Friday, 02 June 2017, 23:32 GMT
Looks like the problem is inside the apm package in fact.
Comment by Nicola Squartini (tensor5) - Saturday, 03 June 2017, 08:49 GMT
You are using nodejs 8.0.0 from Community-Testing, I'll rebuild apm when it moves to Community.
Comment by Balló György (City-busz) - Saturday, 03 June 2017, 12:57 GMT
@tensor5: Please rebuild the apm package in [community-testing] now. We have to ensure that packages work even in the testing repository.
Comment by Nicola Squartini (tensor5) - Saturday, 03 June 2017, 13:53 GMT
Try now.
Comment by Sébastien Luttringer (seblu) - Saturday, 03 June 2017, 18:48 GMT
looks good.

Loading...