Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54261 - [git-annex] Missing distcc build dependency

Attached to Project: Community Packages
Opened by hal clark (h4l) - Thursday, 01 June 2017, 23:20 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 01 June 2017, 23:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Package will not build when distcc is missing. Noticed when compiling for armv7h via Arch Linux ARM. Suggested fix is to add distcc to makedepends.

Another user has also reported the omission and fix: https://archlinuxarm.org/forum/viewtopic.php?f=9&t=11177 (from January 2017)

This is conjecture on my part, but I think the build failure has caused git-annex to be (automatically?) excluded from Arch Linux ARM repo. It would be nice to get it in the repos because compiling Haskell programs natively on ARM machines is unpleasant.


Additional info:
* Version: 6.20170519-12.


Steps to reproduce:
pacman -R distcc
mkdir build && cd build
wget 'https://git.archlinux.org/svntogit/community.git/plain/trunk/PKGBUILD?h=packages/git-annex' -O PKGBUILD
makepkg -s

Output:
...
==> Retrieving sources...
-> Cloning git-annex git repo...
Cloning into bare repository '/home/hal/blah/git-annex'...
Checking connectivity: 182116, done.
==> Validating source files with sha512sums...
git-annex ... Skipped
==> Extracting sources...
-> Creating working copy of git-annex git repo...
Cloning into 'git-annex'...
done.
Checking out files: 100% (10037/10037), done.
Switched to a new branch 'makepkg'
==> Starting build()...
ghc: could not execute: /usr/lib/distcc/bin/gcc
==> ERROR: A failure occurred in build().
Aborting...

This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 01 June 2017, 23:34 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Builds fine. ARM specific issues do not belong here.

Loading...