Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54257 - [pango] Matlab broken - does not find symbol g_log_structured

Attached to Project: Arch Linux
Opened by Christian Schwarz (problame) - Thursday, 01 June 2017, 13:09 GMT
Last edited by Jan de Groot (JGC) - Thursday, 01 June 2017, 13:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

MATLAB Simulink's Simulation->Output->Simulation Data Inspector fails to start with an error indicating the MATLABWindow application could not be started.

Running it manually, a linker error seems to be the cause:
cd /usr/local/MATLAB/R2017a/bin/glnxa64
./MATLABWindow -h
./MATLABWindow: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_log_structured

It doesn't work on
pango-1.40.6+9+g92cc73c8-1-x86_64.pkg.tar.xz
but downgrading to
pango-1.40.5-1-x86_64.pkg.tar.xz
fixed the issue for me.

Looking at the changes made between these versions, I speculate it's some kind of build system bug.

Cheers,

Christian
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 01 June 2017, 13:47 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 01 June 2017, 13:47 GMT
It's not a build system bug and not a packaging bug.

Pango 1.40.6 is built with meson which sets G_LOG_USE_STRUCTURED=1. Previous versions didn't use this macro to enable structured logging. The downside of using structured logging is that pango needs glib>=2.50, so if you have an older version of glib dangling on your system (maybe matlab ships its own copy), pango will fail to resolve the symbol.

Solution is simple: hunt down those outdated glib libraries on your system.

Loading...