Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54217 - [bluez] 5.45-1 "deactivates" Broadcom-card BCM20702A1

Attached to Project: Arch Linux
Opened by Friend of Arch (friendofarch) - Monday, 29 May 2017, 07:24 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 16:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After updating to bluez 5.45-1 it's impossible to use bluetooth device on the laptop.

Installing driver extracted by hand, changing configuration etc didn't help.
Only way I found to get it to work again, was to downgrade to Bluez 5.44-1.

Additional info:
* package version(s)
Bluez 5.45-1

* config and/or log files etc.

systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2017-13-14 12:26:04 CEST; 4 days ago
Docs: man:bluetoothd(8)
Main PID: 617 (bluetoothd)
Status: "Running"
Tasks: 1 (limit: 4915)
CGroup: /system.slice/bluetooth.service
└─617 /usr/lib/bluetooth/bluetoothd

systemd[1]: Starting Bluetooth service...
bluetoothd[617]: Bluetooth daemon 5.45
systemd[1]: Started Bluetooth service.
bluetoothd[617]: Starting SDP server
bluetoothd[617]: Bluetooth management interface 1.14 initialized

dmesg | grep -i bluetooth
[ 20.029624] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[ 21.045337] Bluetooth: Core ver 2.22
[ 21.045355] Bluetooth: HCI device and connection manager initialized
[ 21.045359] Bluetooth: HCI socket layer initialized
[ 21.045361] Bluetooth: L2CAP socket layer initialized
[ 21.045365] Bluetooth: SCO socket layer initialized
[ 24.948877] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 24.948879] Bluetooth: BNEP filters: protocol multicast
[ 24.948883] Bluetooth: BNEP socket layer initialized
[11451.675470] Bluetooth: hci0: BCM: chip id 63
[11451.691527] Bluetooth: hci0: BCM20702A
[11451.692402] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
[11452.637361] Bluetooth: hci0: BCM20702A1 (001.002.014) build 1757
[11452.653431] Bluetooth: hci0: Broadcom Bluetooth Device

Steps to reproduce:

Install bluez 5.45-1 on system with BCM20702A1 bluetooth device.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 21 March 2018, 16:34 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 10 August 2017, 20:39 GMT
Is this still an issue with lastest bluez and kernel updates?
Comment by Felix (makefu) - Wednesday, 15 November 2017, 21:03 GMT
The issue persists with bluez 5.47 , everything regarding hardware and firmware looks fine:

~ dmesg
...
Nov 15 19:46:28 x kernel: Bluetooth: hci0: BCM20702A1 (001.002.014) build 1757
Nov 15 19:46:28 x kernel: Bluetooth: hci0: Broadcom Bluetooth Device

~ rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: no
Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
7: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

~ bluetoothctl
Agent registered
[bluetooth]# power on
No default controller available


I'd love to have this issue fixed, is there anything i can help with finding the root cause?
Comment by Andreas Radke (AndyRTR) - Wednesday, 15 November 2017, 21:44 GMT
Maybe try first latest upstream kernel and bluez-git. If it's not solved post
to the bluez mailing list or file a bug to their upstream tracker!
Comment by Felix (makefu) - Wednesday, 15 November 2017, 22:28 GMT
Ok, i will try bluez from master first, if this does not help i will test the bluetooth subsystem git master - it seems there were a couple of broadcom related commits lately ( https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth.git/log/?qt=grep&q=broadcom ).
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 14:09 GMT
Status? If it's still not solved file an upstream bug and leave the url here to follow.
Comment by Felix (makefu) - Wednesday, 21 March 2018, 16:31 GMT
Issue seems to be resolved with bluez 5.47 for me.

~ bluetoothd --version
5.47

~ bluetoothctl
[NEW] Controller B8:76:3F:AB:0C:3B x [default]
[NEW] Device FF:FF:A0:03:4A:DC AB Shutter3
[NEW] Device 16:09:18:18:0A:44 Bluedio
Agent registered
[bluetooth]#

Loading...