Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54213 - [aide] floating point exception

Attached to Project: Community Packages
Opened by Matteo Pergolesi (thewall) - Sunday, 28 May 2017, 16:26 GMT
Last edited by Lukas Jirkovsky (6xx) - Friday, 23 June 2017, 17:00 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Lukas Jirkovsky (6xx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description: aide commands fail with the result "floating point exception".

I am not reporting this to upstream since latest version is from 2016-07-25 and it was working without problems ~1 month ago.
The same version mentioned here is working correctly at the moment of this report in a Linux Mint virtual machine with the latest updates.

The configuration used is the default one coming with the package.


Additional info:
* package version(s): 0.16-1
* config and/or log files etc.: attached (command output with high verbosity)
* Archlinux Forum thread: https://bbs.archlinux.org/viewtopic.php?pid=1713697#p1713697


Steps to reproduce:
Install the package and run "sudo aide -i": the command fails in a short time. I tried this with ZSH and bash.
This task depends upon

Comment by Lukas Jirkovsky (6xx) - Wednesday, 31 May 2017, 19:36 GMT
What hashes do you use? It works fine for me, but I'm using only md5 (for speed reasons).
Comment by Matteo Pergolesi (thewall) - Thursday, 01 June 2017, 07:18 GMT
I am using the default configuration. Can you provide an example with md5?
Anyway, if this is the problem I think we should write about this in the Archwiki. I can do it after testing your configuration.

Ps. But why default hashes stopped working? Any idea?
Comment by Matteo Pergolesi (thewall) - Monday, 05 June 2017, 10:01 GMT
I changed my configuration file trying to exclude all hashes except md5, but stille getting the exception.

Hope to be helpful.
Comment by Miha Krasovec (TastyCelery) - Tuesday, 06 June 2017, 20:00 GMT
I'm having the same problem. It doesn't matter which hash (or combination of them) I use, AIDE always fails with floating point exception.
The last time I successfully updated AIDE DB was 2017-04-17, after that it's always failing.

I'm attaching aide.conf (mostly default settings) and pacman log if it maybe helps (the last successful AIDE update was done just after 2017-04-17 pacman update).
Comment by Matteo Pergolesi (thewall) - Wednesday, 07 June 2017, 08:27 GMT
I managed to trace back the days aide stopped working for me. I update my system daily. I am attaching my pacman.log relevant to 2017-04-25 and 2017-04-26.
Comment by Lukas Jirkovsky (6xx) - Tuesday, 20 June 2017, 18:12 GMT
Still no luck reproducing it. I tried all hashes and your config, too and it works for me.

Can you try running aide with --verbose=255 and check where it fails? Hopefully that will help to narrow down the problem. Maybe it's one specific file that causes the exception.
Comment by Miha Krasovec (TastyCelery) - Tuesday, 20 June 2017, 22:11 GMT
I installed AIDE also on my laptop and it fails there too, but on different file than server (although both files are from the same package - guile 2.2.2-1)

Attached are txt files with the last screen of verbose data from both machines, server and laptop (I can save more AIDE data if you need it).
Attached are also the files that cause the exception on each machine.
Comment by Matteo Pergolesi (thewall) - Wednesday, 21 June 2017, 08:13 GMT
Same thing happening on my server. Files from guile package make AIDE fail.
Attaching verbose log (last lines only). Thanks for your help.

Ps. I tried to remove guile, but similar error appears for file gnutls.go. Mybe AIDE has problems with go files?
Comment by Lukas Jirkovsky (6xx) - Friday, 23 June 2017, 17:00 GMT
Thank you, I was finally able to reproduce the issue. I reported the bug upstream: https://sourceforge.net/p/aide/bugs/101/

Loading...