Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54177 - [samba] remote code execution from a writable share

Attached to Project: Arch Linux
Opened by loqs (loqs) - Wednesday, 24 May 2017, 21:56 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 27 May 2017, 07:01 GMT
Task Type Bug Report
Category Security
Status Closed
Assigned To Tobias Powalowski (tpowa)
Levente Polyak (anthraxx)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
All versions of Samba from 3.5.0 onwards are vulnerable to a remote
code execution vulnerability, allowing a malicious client to upload a
shared library to a writable share, and then cause the server to load
and execute it.

Additional info:
samba 4.5.8-1 in extra and samba 4.6.3-1 in testing are affected.
https://www.samba.org/samba/security/CVE-2017-7494.html
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 27 May 2017, 07:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in [extra] with samba 4.5.10-1 and in [testing] with samba 4.6.4-1.
Comment by Zhiliang Su (zhilians) - Thursday, 25 May 2017, 09:49 GMT
The package has been flagged "outdated" but even 4.6.3 in testing is affected.

The easiest fix is actually just upgrade to 4.6.4, the patch (https://download.samba.org/pub/samba/patches/samba-4.6.3-4.6.4.diffs.gz) seemed very minimal so we should have just had it testing.
Comment by Chuck (foxcm2000) - Friday, 26 May 2017, 16:21 GMT
This is a pretty severe bug that has already been fixed in other distros. Can we at least get a status update on the fix if you aren't going to release it?

Loading...