Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54170 - [linux] Kernel 4.11.2 does not let user run su or sudo under Enlightenment

Attached to Project: Arch Linux
Opened by David Moore (dave42) - Wednesday, 24 May 2017, 06:34 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 14 June 2017, 14:23 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

See https://phab.enlightenment.org/T5470 and https://bugzilla.kernel.org/show_bug.cgi?id=195799. Due to using ptrace to catch crashes, and a patch in the 4.11 series, you can no longer run "sudo" or "su" under Enlightenment desktop. The author of the patch has fixed this issue in the patch available here: https://bugzilla.suse.com/attachment.cgi?id=726016, so this is a request to patch this into our kernel build until it is upstream. I will be testing this patch, and if it works for me will attach a copy of the patch and my PKGBUILD for the kernel.

Additional info:
* linux 4.11.2-1


Steps to reproduce:
* Upgrade to latest kernel and reboot
* Log in to Enlightenment
* Start a terminal session
* Type 'su' and supply the root password. It will say 'Authentication failed'.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 14 June 2017, 14:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.11.5-1
Comment by David Moore (dave42) - Wednesday, 24 May 2017, 07:55 GMT
I have rebuilt the package with the attached patch, and sudo under Enlightenment works again.
Comment by Barry Denby (barry_denby) - Wednesday, 24 May 2017, 10:27 GMT
I've not tried this patch or fix but I can confirm the same issue here after the update to the new kernel this morning.
Comment by Jerome (jethro) - Wednesday, 24 May 2017, 12:33 GMT
had the same issue after upgrading from 4.10.13 to 4.11.2, fixed by building a kernel with patch applied.
Comment by Adrian Zakrzewski (drazed) - Friday, 26 May 2017, 06:32 GMT
I can also confirm this issue, have not tried the patch/fix.

Additionally chromium won't run without the --no-sandbox flag, due to setuid sandbox not running as root. I believe that is related.
Comment by Chris Bryden (cjbim) - Friday, 26 May 2017, 10:36 GMT
I can confirm this issue, both with chromium and sudo/su, and applying the above patch fixes the problem.
Comment by Regis BROUARD (rebr45) - Tuesday, 30 May 2017, 14:57 GMT
I have the same issue. Sorry to ask but how do we use this patch please ?
Comment by Adrian Zakrzewski (drazed) - Wednesday, 31 May 2017, 07:15 GMT
Still an issue on linux 4.11.3-1
Comment by Barry Denby (barry_denby) - Wednesday, 31 May 2017, 11:22 GMT
I can confirm like Adrian that the new kernel does not resolve this issue.
Comment by y15e (d6er) - Monday, 12 June 2017, 13:20 GMT
Regis, I wrote an instruction of how to use linux-ptrace-fix.patch file.
https://blog.y15e.io/2017/06/12/fix-sudo-error-under-enlightenment-on-arch-linux.html
Comment by Eli Schwartz (eschwartz) - Tuesday, 13 June 2017, 21:06 GMT
This patch has been accepted into the stable queue for 4.11.5, see: https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/tree/queue-4.11/ptrace-properly-initialize-ptracer_cred-on-fork.patch?id=f318ab7e0d8072743181e86a6a235889a8e85ecc

@tpowa,

It seems to me that this is a bothersome enough issue to justify *not* waiting for a new patch release. :) Will you be rebuilding the linux package with this now that it confirmed accepted for 4.11.5?
EDIT: Depending on whether or not 4.11.5 gets released within the next 24 hours anyway, I guess. :o I suppose this is good news for Enlightenment users anyway.

Loading...