Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54151 - [kotlin] REPL throws exception `Unsupported major.minor version 52.0'

Attached to Project: Community Packages
Opened by Vincent (vbmithr) - Sunday, 21 May 2017, 21:41 GMT
Last edited by Alexander F Rødseth (trontonic) - Saturday, 27 May 2017, 10:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F Rødseth (trontonic)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

kotlinc-jvm crashes with `Unsupported major.minor version 52.0'.

Steps to reproduce:

`kotlinc-jvm'. This should start the kotlin REPL.
This task depends upon

Closed by  Alexander F Rødseth (trontonic)
Saturday, 27 May 2017, 10:20 GMT
Reason for closing:  Fixed
Comment by Vincent (vbmithr) - Sunday, 21 May 2017, 22:11 GMT
This happens when both JDK7 and JDK8 are installed. When I uninstalled JDK7, the problem did not occur.
Comment by Doug Newgard (Scimmia) - Monday, 22 May 2017, 15:51 GMT
Don't need to uninstall it, just use archlinux-java to make 8 the default.

Looks like the version requirement needs updated, but that still won't automatically select 8 as the default; that's up to the user.
Comment by Alexander F Rødseth (trontonic) - Saturday, 27 May 2017, 10:20 GMT
Updated the dependency to be on java-environment>=8

Loading...