Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54117 - [ejabberd] missing module in default config prevents s2s communication

Attached to Project: Community Packages
Opened by Regged User (regged_user) - Friday, 19 May 2017, 15:53 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 22 May 2017, 12:46 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since ejabberd 17.03 dialback s2s logic was moved into separate module, but this module is not presented in default Archlinux configuration, thus fresh installations of ejabberd will fail to connect to a lot of xmpp servers. Affected users will see error in their ejabberd.log similar to this:

2017-05-19 15:08:41.713 [info] <0.567.0>@ejabberd_s2s_out:handle_auth_failure:242 (tls|<0.573.0>) Failed outbound s2s EXTERNAL authentication user_node -> remote_node (8.8.8.8): Authentication failed: Peer provided no SASL mechanisms

To fix this error one have to add line
mod_s2s_dialback: {}
to the "modules" secion of ejabberd.yml

Additional info:
* package version: 17.04-2



Steps to reproduce:
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 22 May 2017, 12:46 GMT
Reason for closing:  Fixed
Comment by Regged User (regged_user) - Friday, 19 May 2017, 16:55 GMT
Why type was changed to "feature request"? This config option exist in default ejabberd configuration and without it ejabberd can't connect to many servers (for example jabber.ru and gmail.com). Default Archlinux config does not contain this option (even commented) and upgrading users will suffer from inability to connect to remote servers. It's a regression, not a feature.
Comment by Sergej Pupykin (sergej) - Monday, 22 May 2017, 12:46 GMT
looks fixed in 17.04:
# grep s2s_d ejabberd.yml
mod_s2s_dialback: {}

Loading...