FS#54087 - [hplip] hp-systray segfaults on Pentium M

Attached to Project: Arch Linux
Opened by Stefan Förster (HotblackDesiato) - Tuesday, 16 May 2017, 15:23 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 11 August 2017, 14:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: hp-systray of the package hplip (3.17.4-1) segfaults on my IBM ThinkPad X41 (Pentium M):

HP Linux Imaging and Printing System (ver. 3.17.4)
System Tray Status Service ver. 2.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Segmentation fault (core dumped)

Steps to reproduce:
Install hplip and hplip-plugin on a 32bit machine.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 11 August 2017, 14:27 GMT
Reason for closing:  None
Comment by Andreas Radke (AndyRTR) - Tuesday, 16 May 2017, 15:32 GMT
The hplip-plugin pkg is AUR stuff and thus unsupported here. And btw: i686 support is fading out here.
Comment by Stefan Förster (HotblackDesiato) - Tuesday, 16 May 2017, 15:51 GMT
hp-systray is in hplip package of extra repository. It is still offered for i686.
Comment by Doug Newgard (Scimmia) - Thursday, 18 May 2017, 16:01 GMT
Yes, it's still supported for another 6 months. Wouldn't surprise me if this sits until then and is then closed.
Comment by Stefan Förster (HotblackDesiato) - Saturday, 20 May 2017, 06:41 GMT
It is a shame that old machines are no longer being supported. That has always been a big advantage of GNU/Linux. Now we are even worse than Microsoft... But thanks for your support anyway. I will watch out for another distro for my older computers - or better for all my machines, since Arch now sucks.
Comment by Andreas Radke (AndyRTR) - Saturday, 20 May 2017, 19:29 GMT
If you want to help fixing your bug please provide a gdb backtrace with debug symbols.
Comment by Stefan Förster (HotblackDesiato) - Sunday, 25 June 2017, 08:52 GMT
Hi Andreas and Doug, thanks for your willingness to support i686 ;-)

I solved my problem by manually installing hplip-3.17.6 from the source. Compilation worked without any problems:

./configure --enable-qt5
make all
make install

The installation somehow forgot to install four python modules properly, which triggered the error message "ImportError: No module named cupsext", which is obviously a problem for years in various distros.

I found the missing modules in the sub-folder ".libs" of the folder that I used for the making the driver. I copied the files to "/usr/lib/python3.6/site-packages/". The four files are:


Since I was able to compile and successfully run the driver and in particular hp-systray, it seems that the hplip package just needs to be recompiled to avoid the segfault. I used the most recent version 3.17.6. Maybe it is version 3.17.4 that causes trouble ?
Comment by Andreas Radke (AndyRTR) - Sunday, 25 June 2017, 16:06 GMT
3.17.6-2 - grepping for built .so files showed them for both architectures. Please confirm the rebuilt package to be working.
Comment by Stefan Förster (HotblackDesiato) - Saturday, 01 July 2017, 05:22 GMT
I installed the new packages. Unfortunately still segfault. I reverted back to my own compilation from sources, which I can confirm to be working.

My CFLAGS are: -march=pentium-m -O2 -pipe -fomit-frame-pointer --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2

I use my own custom kernel (still 4.6.7, will update soon). I am not sure whether this is relevant, since usually all programs run equally well under the stock kernel and my own.
Comment by Andreas Radke (AndyRTR) - Thursday, 10 August 2017, 20:20 GMT
New version is out. Does it work now?
Comment by Stefan Förster (HotblackDesiato) - Friday, 11 August 2017, 06:05 GMT
I believe that you can close this bug ticket. I found that also a few other applications (e.g. Okular and LibreOffice) segfault on my notebook. It must be some buggy library or the like, I can't find it. Curiously the hplip version compiled by me works perfectly. I really now think that the official package isn't the reason for the segfault.