Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54076 - [networkmanager] 1.8.0 segfault on startup

Attached to Project: Arch Linux
Opened by Daan van Rossum (drrossum) - Tuesday, 16 May 2017, 07:46 GMT
Last edited by Jan de Groot (JGC) - Saturday, 08 July 2017, 21:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:

After upgrading to networkmanager 1.8.0-1, NetworkManager segfaults on startup:

((src/platform/nm-platform.c:2650)): assertion '<dropped>' failed
g_array_sort_with_data: assertion 'array != NULL' failed


Version 1.8rc3+10+gddd6f94ab-1 does not show this problem.


Steps to reproduce:
Restart the NetworkManager service and it segfaults again in the same way
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 08 July 2017, 21:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.8.2-1
Comment by tranqil (tranqil) - Tuesday, 16 May 2017, 13:49 GMT
Same problem here, but only if I try to establish a wwan connection using the modem-broadband. For me eifi and wired connection are not afflicted.

The last working package version is: networkmanager-1.8rc3+10+gddd6f94ab-1-x86_64.pkg.tar.xz
Comment by Thomas (kugel.) - Wednesday, 17 May 2017, 05:40 GMT
I am affected too. Happens when I try to connect to a BT tethering connection.
Comment by David (thip) - Monday, 22 May 2017, 17:33 GMT
This is happening to me too when I try to connect using my wwan card
Comment by Ryan (bosco) - Tuesday, 23 May 2017, 21:45 GMT
I've confirmed this issue as well on two x86_64 laptops and an ARM device
Comment by Emantor (Emantor) - Monday, 05 June 2017, 14:08 GMT
Disableing IPv6 support on the WWAN interface fixes the problem for me.

They reworked IPv6 capturing support from 1.8-rc3 to 1.8.0, I haven't found out what exactly broke.
Comment by Jared Baldridge (jrb) - Tuesday, 06 June 2017, 02:24 GMT
I did a little digging today, and found this broke in commit a65e102472bf934ba816da97e2592a36b4c3c335, shortly before 1.8.0, but has been fixed in the 1.8 branch with 390cfec7929c215f662260d3bffbf9e3198f0602. Since 1.8.1 hasn't been released with the fix yet, here's a patch backporting the fix to 1.8.0. I've rebuilt the package locally with this patch, and it has resolved the segfault issues for me.

Loading...