Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#5406 - abiword 2.4.5-1 crashes opening a word (*.doc) file

Attached to Project: Arch Linux
Opened by Herbert (mumpf) - Friday, 15 September 2006, 16:04 GMT
Last edited by Alexander Baldeck (kth5) - Tuesday, 19 September 2006, 18:10 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To dorphell (dorphell)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date 2006-09-30
Percent Complete 100%
Votes 0
Private No

Details

1. I open abiword (current/abiword 2.4.5-1)
2. I try to open a *.doc file (created with Word 2003) either from harddisk (ext3) or usb-stick (vfat)
3. abiword is being closed instantly

This does not happen with ascii-files, which I try to open.

This happened in xfce4, but after I installed gnome, this happens in gnome as well

However when I make my own abiword with bash abiword-2.4.5.x86.package abiword works fine with the same *.doc!
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 23 December 2006, 22:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Updated to 2.4.6
Comment by Jan de Groot (JGC) - Wednesday, 20 September 2006, 09:41 GMT
I guess this must be a bug in libwv then, as the default abiword uses its internal copy of libwv, while we build with the system-installed version.
Comment by Nadav (thesamet) - Monday, 13 November 2006, 16:34 GMT
the bug happens here as well.
Comment by aidenn (idn) - Sunday, 19 November 2006, 14:55 GMT
same here.
Comment by aidenn (idn) - Tuesday, 19 December 2006, 00:00 GMT
> I guess this must be a bug in libwv then, as the default abiword uses its internal copy of libwv, while we build with the system-installed version.

it's not, I've compiled Abiword 2.4.6 using old PKGBUILD (with system-installed wv) and the crash doesn't happen anymore.

Loading...