Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54059 - [mono] Sonarr crashes with segfault on mono 5

Attached to Project: Arch Linux
Opened by Steve M (smmalis37) - Monday, 15 May 2017, 03:31 GMT
Last edited by Isenmann Daniel (ise) - Monday, 15 May 2017, 20:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When running Sonarr (a program that runs on top of Mono) with the recently released Mono 5 package, it will segfault after a few minutes. The core dump indicates something to do with how mono is talking to libcrypto regarding ssl connections to be the cause. The full details that get output to journalctl are attached. I am not the only one seeing this problem per irc conversations and https://www.reddit.com/r/sonarr/comments/6b3ifc/sonarrs_crashing_because_of_something_to_do_with/.


Steps to reproduce:
Run Sonarr (available in AUR) on top of Mono 5
Add an indexer that uses HTTPS to connect
Wait for an RSS sync to take place
Observe segfault
   dump.txt (55.6 KiB)
This task depends upon

Closed by  Isenmann Daniel (ise)
Monday, 15 May 2017, 20:56 GMT
Reason for closing:  Not a bug
Comment by Isenmann Daniel (ise) - Monday, 15 May 2017, 20:56 GMT
Like stated in the Reddit entry and on the sonarr page, you have to add MONO_TLS_PROVIDER=legacy as environment variable before running sonarr. Mono changed it to a new behaviour and it seems that some programs don't behave correctly. So it's not a bug in mono.

Loading...