Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54046 - hashcat pkgver 3.5.0-1 smaller than 3.40-1

Attached to Project: Community Packages
Opened by Li Jinpei (lijinpei) - Sunday, 14 May 2017, 15:26 GMT
Last edited by Levente Polyak (anthraxx) - Monday, 22 May 2017, 16:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
On 2017-05-13, hashcat from community repo upgraded to version 3.5.0-1 following upstream, however, according to pacman's comparation algorithm, this new pkgver is smaller than the old one 3.40-1, which leads to hashcat installed before 2017-05-13 not being able to be upgraded with 'pacman -Syu'.
Aftering asking around in my local community, farseerfc thought that adding a epoch to the pkgver could be a solution.

Ref:
https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/hashcat&id=9912cd922858663eadc009b06d18f6b7786e59e7
https://hashcat.net/hashcat/
https://www.archlinux.org/pacman/vercmp.8.html

Additional info:
hashcat 3.5.0-1


Steps to reproduce:
Step 1: Install hashcat before 2017-05-13
Step 2: Try 'pacman -Syu' after 2017-05-13.
Wrong results: warning: hashcat: local (3.40-1) is newer than community (3.5.0-1)
This task depends upon

Closed by  Levente Polyak (anthraxx)
Monday, 22 May 2017, 16:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  1:3.5.0-1

Loading...