Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54034 - [python2-backports.functools_lru_cache] File conflicts with python2-backports

Attached to Project: Arch Linux
Opened by Alex Forencich (alex.forencich) - Sunday, 14 May 2017, 04:35 GMT
Last edited by Felix Yan (felixonmars) - Sunday, 14 May 2017, 14:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 29
Private No

Details

Description: Files in this package conflict with python2-backports, which is a dependency of this package.


Additional info:
* python2-backports.funcutils_lru_cache 1.4-1
* python2-backports 1.0-1


Steps to reproduce:

* Install python2-backports
* Attempt to install python2-backports.funcutils_lru_cache
* Fails with:

error: failed to commit transaction (conflicting files)
python2-backports.functools_lru_cache: /usr/lib/python2.7/site-packages/backports/__init__.py exists in filesystem
python2-backports.functools_lru_cache: /usr/lib/python2.7/site-packages/backports/__init__.pyc exists in filesystem
Errors occurred, no packages were upgraded.

$ pacman -Qo /usr/lib/python2.7/site-packages/backports/__init__.py
/usr/lib/python2.7/site-packages/backports/__init__.py is owned by python2-backports 1.0-1
This task depends upon

Closed by  Felix Yan (felixonmars)
Sunday, 14 May 2017, 14:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.4-2
Comment by Bruno Pagani (ArchangeGabriel) - Sunday, 14 May 2017, 10:04 GMT
I don’t even understand how this has gone unnoticed, since python2-backports.functools_lru_cache depends on python2-backports, so the devtools script should have returned an issue at the install trial.

Loading...