Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54011 - [jenkins] PLEASE ENTER SUMMARY

Attached to Project: Community Packages
Opened by binhex (binhex) - Thursday, 11 May 2017, 09:37 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 11 May 2017, 13:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I am seeing a HTTP Response Code 404 when downloading Jenkins from mirror, this seems to happen on every release, where if you attempt to download stragiht after the version number has changed then the file isn't there, if you wait an hour or so it then downloads correctly.

I have seen this issue 2 times now, see below for timings:-

2017-05-01 T14:57:37 UTC Jenkins 2.58-1
2017-05-11 T06:51:25 UTC Jenkins 2.60-1

Both times i got a 404 when attempting to download the package.

In short i would like to request that the version number for the package is NOT changed until the download has been pushed out to all mirrors and is accessible, this should then hopefully prevent any future 404 errors.

Link to docker console output showing the 404:-
https://hub.docker.com/r/binhex/arch-jenkins/builds/bkno7fwenrnqwjpxyspg3uv/

Steps to reproduce: Wait for new release to be posted, attempt to download the package and see it fail with a 404
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 11 May 2017, 13:46 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Mirror lag. You shouldn't be downloading from https://www.archlinux.org/packages/commu nity anyway

Loading...