AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#53956 - Account removal results in owned packages removed from web interface

Attached to Project: AUR web interface
Opened by Petteri Tolonen (pretseli) - Sunday, 07 May 2017, 05:14 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 05 November 2017, 10:03 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.4.0
Due in Version 4.6.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I deleted my AUR account since I don't use Arch much nowadays and you provide the possibility to remove my account. I assumed the packages I owned would be orphaned as a result, but instead they have disappeared from the web interface. However, the Git repositories for the packages still seem to exist (I can fetch all commits from remote).
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 05 November 2017, 10:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/aurweb.git/com mit/?id=e06773add6bbecdf9ce797412ff01257 80ba635d
Comment by Petteri Tolonen (pretseli) - Sunday, 07 May 2017, 05:24 GMT
My AUR username was rudolf and the packages I owned were: freedink, freedink-data, freedink-dfarc, jugglinglab, hexen2 and vimchant.
Comment by Lukas Fleischer (lfleischer) - Sunday, 07 May 2017, 05:24 GMT
Deleting a user account should indeed orphan (and not delete) any package bases owned by the removed user.

Could you please list the packages affected by this so we can investigate?
Comment by Petteri Tolonen (pretseli) - Sunday, 07 May 2017, 08:06 GMT
That's funny.. I answered just before you asked :-). See my previous comment for a list of packages.
Comment by Petteri Tolonen (pretseli) - Sunday, 07 May 2017, 13:09 GMT
(accidental repost)
Comment by Aleksandr (4le34n) - Friday, 28 July 2017, 05:36 GMT
I confirm.
Comment by Lukas Fleischer (lfleischer) - Friday, 28 July 2017, 06:33 GMT
I am puzzled. We explicitly orphan package bases before deleting a user account, see [1]. So even if propagation constraints are broken on our live setup, everything should still work as expected (i.e. orphan maintained packages instead of removal).

[1] https://git.archlinux.org/aurweb.git/tree/web/lib/acctfuncs.inc.php#n910
Comment by Aleksandr (4le34n) - Tuesday, 01 August 2017, 04:04 GMT
To reproduce the problem, you must be the first owner of the package.

Loading...