Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53942 - [midori] unable to build this package in a clean chroot

Attached to Project: Community Packages
Opened by John (graysky) - Friday, 05 May 2017, 20:05 GMT
Last edited by Alexander F. Rødseth (xyproto) - Sunday, 07 May 2017, 15:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When building in a new clean chroot, makepkg errors out for me. Log file is attached; relevant lines in the FS:

...
[76/256] cd /build/midori/src/midori-0.5.11/build/data && /usr/bin/rsvg-convert --keep-aspect-ratio --format=png /build/midori/src/midori-0.5.11/data/logo-shade.svg --output /build/midori/src/midori-0.5.11/build/data/logo-shade.png
[77/256] Generating /build/midori/src/midori-0.5.11/midori/../katze/katze-separatoraction.c;/build/midori/src/midori-0.5.11/midori/../katze/midori-hsts.c;/build/midori/src/midori-0.5.11/midori/../katze/midori-paths.c;/build/midori/src/midori-0.5.11/midori/../katze/midori-uri.c;/build/midori/src/midori-0.5.11/midori/midori-bookmarksdatabase.c;/build/midori/src/midori-0.5.11/midori/midori-completion.c;/build/midori/src/midori-0.5.11/midori/midori-contextaction.c;/build/midori/src/midori-0.5.11/midori/midori-database.c;/build/midori/src/midori-0.5.11/midori/midori-dialog.c;/build/midori/src/midori-0.5.11/midori/midori-download.c;/build/midori/src/midori-0.5.11/midori/midori-extensions-column.c;/build/midori/src/midori-0.5.11/midori/midori-historycompletion.c;/build/midori/src/midori-0.5.11/midori/midori-historydatabase.c;/build/midori/src/midori-0.5.11/midori/midori-notebook.c;/build/midori/src/midori-0.5.11/midori/midori-panedaction.c;/build/midori/src/midori-0.5.11/midori/midori-searchcompletion.c;/build/midori/src/midori-0.5.11/midori/midori-settings.c;/build/midori/src/midori-0.5.11/midori/midori-speeddial.c;/build/midori/src/midori-0.5.11/midori/midori-tab.c;/build/midori/src/midori-0.5.11/midori/midori-viewable.c;/build/midori/src/midori-0.5.11/midori/midori-viewcompletion.c;/build/midori/src/midori-0.5.11/midori/midori-window.c;midori-core.vapi;midori-core.h
FAILED: midori/midori_valac.stamp
cd /build/midori/src/midori-0.5.11/build/midori && /usr/bin/valac -C --header=midori-core.h --library=midori-core --vapi=midori-core.vapi -b /build/midori/src/midori-0.5.11/midori -d /build/midori/src/midori-0.5.11/build/midori --pkg=posix --pkg=linux --pkg=libxml-2.0 --pkg=sqlite3 --pkg=gmodule-2.0 --pkg=gio-2.0 --pkg=libsoup-2.4 --pkg=zeitgeist-2.0 --pkg=gtk+-3.0 --enable-deprecated --debug -D HAVE_EXECINFO_H -D HAVE_LIBSOUP_2_40_0 -D HAVE_LIBSOUP_2_48_0 -D HAVE_GTK3 -D HAVE_WEBKIT2 -D HAVE_WEBKIT2_3_91 /build/midori/src/midori-0.5.11/midori/../katze/katze-separatoraction.vala /build/midori/src/midori-0.5.11/midori/../katze/midori-hsts.vala /build/midori/src/midori-0.5.11/midori/../katze/midori-paths.vala /build/midori/src/midori-0.5.11/midori/../katze/midori-uri.vala /build/midori/src/midori-0.5.11/midori/midori-bookmarksdatabase.vala /build/midori/src/midori-0.5.11/midori/midori-completion.vala /build/midori/src/midori-0.5.11/midori/midori-contextaction.vala /build/midori/src/midori-0.5.11/midori/midori-database.vala /build/midori/src/midori-0.5.11/midori/midori-dialog.vala /build/midori/src/midori-0.5.11/midori/midori-download.vala /build/midori/src/midori-0.5.11/midori/midori-extensions-column.vala /build/midori/src/midori-0.5.11/midori/midori-historycompletion.vala /build/midori/src/midori-0.5.11/midori/midori-historydatabase.vala /build/midori/src/midori-0.5.11/midori/midori-notebook.vala /build/midori/src/midori-0.5.11/midori/midori-panedaction.vala /build/midori/src/midori-0.5.11/midori/midori-searchcompletion.vala /build/midori/src/midori-0.5.11/midori/midori-settings.vala /build/midori/src/midori-0.5.11/midori/midori-speeddial.vala /build/midori/src/midori-0.5.11/midori/midori-tab.vala /build/midori/src/midori-0.5.11/midori/midori-viewable.vala /build/midori/src/midori-0.5.11/midori/midori-viewcompletion.vala /build/midori/src/midori-0.5.11/midori/midori-window.vala /build/midori/src/midori-0.5.11/midori/webkit2gtk-4.0.vapi /build/midori/src/midori-0.5.11/katze/katze.vapi && touch /build/midori/src/midori-0.5.11/build/midori/midori_valac.stamp
/build/midori/src/midori-0.5.11/midori/midori-notebook.vala:330.25-330.39: error: Access to non-public constructor `Midori.Tally.new' denied
var tally = new Tally (tab);
^^^^^^^^^^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
[78/256] cd /build/midori/src/midori-0.5.11/build/data && /usr/bin/intltool-merge --desktop-style /build/midori/src/midori-0.5.11/po /build/midori/src/midori-0.5.11/data/midori.desktop.in midori.desktop
Merging translations into midori.desktop.
[79/256] cd /build/midori/src/midori-0.5.11/build/data && /usr/bin/intltool-merge --desktop-style /build/midori/src/midori-0.5.11/po /build/midori/src/midori-0.5.11/data/midori-private.desktop.in midori-private.desktop
Merging translations into midori-private.desktop.
[80/256] cd /build/midori/src/midori-0.5.11/build/data && /usr/bin/intltool-merge --xml-style /build/midori/src/midori-0.5.11/po /build/midori/src/midori-0.5.11/data/midori.appdata.xml.in midori.appdata.xml
Merging translations into midori.appdata.xml.
CREATED midori.appdata.xml
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Build failed, check /scratch/.chroot64/facade/build

Additional info:
* package version(s) 0.5.11-5

This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Sunday, 07 May 2017, 15:16 GMT
Reason for closing:  Fixed
Comment by Alexander F. Rødseth (xyproto) - Saturday, 06 May 2017, 12:00 GMT
Thanks for reporting. My hunch is that this is caused by the latest vala upgrade and should be fixed in the Midori source code. I'll see if I can find a patch while waiting for the next release.

Loading...